Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Software center not opening

I am brand new to Linux and Ubuntu, and I couldn't install GIMP without the software center. I looked up earlier how to fix it, and it said to fix my sources list, and I did, but now i get a new error in the terminal.

2012-08-14 15:29:08,941 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2012-08-14 15:29:08,954 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2012-08-14 15:29:09,407 - softwarecenter.ui.gtk3.app - INFO - building local database
2012-08-14 15:29:09,408 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
2012-08-14 15:29:17,308 - softwarecenter.db.update - WARNING - Problem creating rebuild path '/var/cache/software-center/xapian_rb'.
2012-08-14 15:29:17,309 - softwarecenter.db.update - WARNING - Please check you have the relevant permissions.
2012-08-14 15:29:17,309 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2012-08-14 15:29:18,039 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2012-08-14 15:29:18,431 - softwarecenter.ui.gtk3.app - INFO - show_available_packages: search_text is '', app is None.
2012-08-14 15:29:19,153 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
Traceback (most recent call last):
  File "/usr/bin/software-center", line 176, in <module>
    app.run(args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 1422, in run
    self.show_available_packages(args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 1352, in     show_available_packages
    self.view_manager.set_active_view(ViewPages.AVAILABLE)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/viewmanager.py", line 154, in set_active_view
    view_widget.init_view()
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/availablepane.py", line 136, in init_view
    SoftwarePane.init_view(self)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/softwarepane.py", line 215, in init_view
    self.icons, self.show_ratings)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/appview.py", line 69, in __init__
    self.helper = AppPropertiesHelper(db, cache, icons)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/models/appstore2.py", line 109, in __init__
    softwarecenter.paths.APP_INSTALL_PATH)
  File "/usr/share/software-center/softwarecenter/db/categories.py", line 255, in parse_applications_menu
    category = self._parse_menu_tag(child)
  File "/usr/share/software-center/softwarecenter/db/categories.py", line 444, in _parse_menu_tag
    query = self._parse_include_tag(element)
  File "/usr/share/software-center/softwarecenter/db/categories.py", line 402, in _parse_include_tag
    xapian.Query.OP_AND)
  File "/usr/share/software-center/softwarecenter/db/categories.py", line 341, in _parse_and_or_not_tag
    operator_elem, xapian.Query(), xapian.Query.OP_OR)
  File "/usr/share/software-center/softwarecenter/db/categories.py", line 385, in _parse_and_or_not_tag
    q = self.db.xapian_parser.parse_query(s,
  File "/usr/share/software-center/softwarecenter/db/database.py", line 174, in xapian_parser
    xapian_parser = self._get_new_xapian_parser()
  File "/usr/share/software-center/softwarecenter/db/database.py", line 200, in _get_new_xapian_parser
    xapian_parser.set_database(self.xapiandb)
  File "/usr/share/software-center/softwarecenter/db/database.py", line 166, in xapiandb
    self._db_per_thread[thread_name] = self._get_new_xapiandb()
  File "/usr/share/software-center/softwarecenter/db/database.py", line 179, in _get_new_xapiandb
    xapiandb = xapian.Database(self._db_pathname)
  File "/usr/lib/python2.7/dist-packages/xapian/__init__.py", line 3666, in __init__
_xapian.Database_swiginit(self,_xapian.new_Database(*args))
xapian.DatabaseOpeningError: Couldn't detect type of database

I'm not sure how to fix the errors, and I couldn't find a topic on them anywhere. Be nice, because I am a two-day old Linux user :/

Tell me if you need my Sources list

share|improve this question

marked as duplicate by jokerdino, Eliah Kagan, Jorge Castro, Mitch, Bruno Pereira Sep 8 '12 at 6:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

1 Answer 1

Welcome to the world of Ubuntu and Linux. You might have a problem with you repositories. Go to this answer to set your repositories to how they were originally. Then try to start the Software Center again.

If it still doesn't work, you can try to reinstall the Ubuntu Software Center.

To do that, open the Terminal, and run the following commands:

sudo apt-get remove software-center

sudo apt-get autoremove software-center

Then

sudo apt-get update

sudo apt-get install software-center

As for your problem with sources.list permissions being read only, try this:

Go into the Terminal(short cut is Ctrl+Alt+t) or look for it in the dash.

In there type:

gksudo nautilus

Now enter you password, and you will be logged in as root. Now click on "File System". Now Click on the folder "etc", followed by clicking on the folder "apt". Now right click on the file "sources.list". In the pop down menu, click on "Properties". Now click on the tab "Permissions". Set your permission exactly as in the picture and click close.

Permissions for sources.list

While you are here now, you can edit your sources.list. If you live in the United States, you can use this. If not, use this only as reference and go to the first part of the answer. He is my source.list. Now make sure to save it.


Now try again to reinstall the Software Center.

Tell me if it works first, and then we will address the Microsoft Eula.

share|improve this answer
1  
Ok, two things: I can't edit my sources.list anymore because I can't figure out how to make it NOT read-only. Second, whenever I tried to remove software-center, this Microsoft EULA notice came up and I couldn't get it to leave. I'm not sure if it worked or not, because after that i couldn't remove it because it couldn't find software center. whenever i tried to install it, i got the 'E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?' error. –  Nathan Weisser Aug 16 '12 at 15:53
    
Where you running a update during the time you got (/var/lib/dpkg/)? This is a common error if you are running the update manager and try to install or edit the sources. I am going to update my answer to try to fix the permissions problem. –  Max Tither Aug 16 '12 at 16:08
    
I added more information. Try this out now. As for the Microsoft Eula, what does it say. –  Max Tither Aug 16 '12 at 16:42
    
Hey thanks! I used your sources.list and that fixed everything! Awesome! all i wanted was gimp... now where do I mark this post as solved... –  Nathan Weisser Aug 18 '12 at 5:21
    
Glad to help. Is there a way to go over the answer and mark it as the best? –  Max Tither Aug 18 '12 at 5:28
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.