Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am wondering if all I need to do is add the disks to the fstab (Ubuntu 12.04LTS desktop) They are both 1 TB internal hard drives This site has my text going bold like crazy \ formatting

using sudo gedit /etc/fstab to get into the file to modify what drives mount on the boot

original fstab

proc            /proc           proc    nodev,noexec,nosuid 0       0
UUID=77d01510-9a51-4818-850c-da05654442f7 /               ext4    errors=remount-ro 0       1

UUID=43ebb068-1983-45a4-b2b7-303caec17d16 none            swap    sw              0       0

The changed being

proc            /proc           proc    nodev,noexec,nosuid 0       0
UUID=77d01510-9a51-4818-850c-da05654442f7 /               ext4    errors=remount-ro 0       1

UUID=43ebb068-1983-45a4-b2b7-303caec17d16 none            swap    sw              0       0

UUID=77d01510-9a51-4818-850c-da05654442f7 /media/1.0Ubuntu ext4 defaults 0 1

UUID=7CB810DBB810962C /media/New Volume ntfs default 0 1 

UUID from blkid and mount pt from disk utility in case anyone is using this. dump is for archiving so I left at 0 and pass is a disk check (found on wikipedia) so i put 2 so it checks after the root. defaults was just to fill the options.

share|improve this question
1  
This is a forum and there is no need to add "[Solved]" to the title. Looking carefully at question listings, you can see what questions are solved. –  hexafraction Aug 15 '12 at 16:20
    
If there is further info to add on how it was "solved" please add as an answer, or edit the "accepted" answer to include additional info. –  Mateo_ Sep 20 '12 at 1:26

4 Answers 4

up vote 0 down vote accepted

Automounting at boot is a question of modifying the fstab file.

My experience with Precise is that you may use the UUID but the drive gets two entries in Nautilus devices list. When I changed to /dev/sdb* it worked flawlessly.

share|improve this answer
    
yeah i am getting the 2 device entries now. I will try that out. also needed to put \040 for any spaces in the device names or it wont boot with out pressing S –  drew4452862 Aug 14 '12 at 20:50
    
If you liked my answer please accept it by upvoting it. Thanks. –  To Do Aug 15 '12 at 12:13
    
I clicked it for the answer but can not upvote until i get 15 posts. Might be able to get back to it –  drew4452862 Aug 15 '12 at 16:15
    
Yes you're right. But you accepted it as the best answer. That is just as good if not better. –  To Do Aug 15 '12 at 17:23

So I looking for the same answer only based on udisks? I've found that possible do it in opensuse like this

touch /var/lib/polkit-1/localauthority/10-vendor.d/org.freedesktop.udisks.filesystem-mount-system-internal.pkla 

insert in it

[org.freedesktop.udisks.filesystem-mount-system-internal]
Identity=unix-group:*
Action=org.freedesktop.udisks.filesystem-mount-system-internal
ResultAny=auth_admin
ResultInactive=auth_admin
ResultActive=yes

Is any possibility that this will working for ubuntu and have that by default. Because if it will presented by default no question about internal mounting appear. fstab not really good for additional drives nor flexible. I think it must contain only system important records.

share|improve this answer

for the 'options' field, use defaults with an s instead of the singular. It took me some time to figure that out, now works fine.

share|improve this answer

To answer the original question all you need to do is edit the fstab file by typing sudo -i gedit /etc/fstab in the terminal.

Currently Linex prefers the use of the UUID in the fstab file because the sd*# device assignments can change under certain circumstances between system boots resulting in failed mount attempts.

To fine the UUID for the drive you want to mount type sudo blkid in the terminal.

To check if you were successful type sudo mount -a in the terminal to remount the disk.

share|improve this answer
    
Thanks for correcting me. –  mike100111 Mar 6 at 20:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.