Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am installing pygame for Python3.2 because I want to do all the examples shown in a book, but on Ubuntu 12.04 I only have pygame for python version 2.7. But that is not as good as I want it. So I started to do it like here

But, when starting this command:

python3.2 config.py

there were this output:

PORTMIDI: not found
PORTTIME: not found
AVFORMAT: not found
SWSCALE : not found

What should I do, so I can install pygame without any problems ?

share|improve this question

1 Answer 1

It looks like some Pygame dependencies are missing.

I'd suggest installing these packages:

  • libportmidi-dev - library for real-time MIDI input/output
  • libportmidi0 - library for real-time MIDI input/output
  • libavformat-dev - development files for libavformat
  • libavformat52 - ffmpeg file format library
  • libswscale-dev - development files for libswscale
  • libswscale0 - ffmpeg video scaling library

    sudo apt-get install libportmidi-dev libportmidi0 libavformat-dev libavformat52 libswscale-dev libswscale0

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.