Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have lenovo g460 with VGA compatible controller: nVidia Corporation GT218 [GeForce 310M] (rev a2) grapics card

I have install the driver using gksudo jockey-gtk command, but when I change the visual effects to extra its give me 'Desktop effects could not be enabled'. I am new to Ubuntu.

share|improve this question
    
Is jockey-gtk the tool that the "HArdware Drivers" GUI uses? Or is it something seperate. –  tj111 Jan 14 '11 at 18:49
add comment

3 Answers

First go to console (ALT+F2 then type gnome-terminal). Inside the console type nvidia and press the TAB button. If you have the nvidia drivers correctly install there should appear several nvidia files (Like nvidia-settings, nvidia-xconfig, etc..)

Type nvidia-xconfig so it edits the xorg.conf file with the nvidia configs. Reboot the PC.

If you can not still have special effects then do the following: nvidia-current

  1. Install mesa-utils (sudo aptitude install mesa-utils or sudo apt-get install mesa-utils)
  2. Type glxinfo | grep "direct rendering". If a NO appears then there is some problem with your nvidia installs. If a YES appears then typing compiz --replace after pressing ALT+F2 should give you the 3D effects.

  3. If the NO appeared just try to reinstall the drivers with sudo aptitude reinstall nvidia-current

  4. Lastly type dmesg | grep "nvidia" in console to see if there is an output regarding nvidia. Normally the output will say how to fix it.

share|improve this answer
    
I Have the same problem and CYREX's advice worked, but when i log out and back in the effects are gone again?? Any idea how i keep them the way they are without having to redo the "compiz --replace"? TYVM :-) –  Donald Dorn Jr Jan 14 '11 at 19:04
add comment

Following instructions given by CYREX, in order to manage easily visual effect, I would suggest to install Ubuntu Tweak. Than from Ubuntu Tweak check 'Install Simple Desktop Effect Setting Manager'. Run application from System/Preferences/Simple CompizConfig Settings Manager. Ubuntu Tweak 0.5.7

share|improve this answer
    
-1 - Ubuntu Tweak is dangerous if you don't know what you're doing. –  jrg Jun 8 '11 at 15:17
    
Hello James ! I think, any operating system is dangerous for people who has no idea how to use it :) –  Vincenzo Jun 8 '11 at 15:35
1  
I agree that it is better not to use Ubuntu tweaks in 11.04. Unfortunately, I had so many annoying "features" in 11.04 so I did a downgrade to 10.10 - now everything works well :) –  Vincenzo Jun 8 '11 at 15:39
    
Agreed there! However, Ubuntu tweak makes it dangerously easy to mess up your system - in my experience, it's pretty hard to mess it up without trying to - but Ubuntu tweak exposes a lot of snares that can get you into real trouble. :) –  jrg Jun 8 '11 at 15:40
add comment

you may want to try my solution:

add "compiz --replace" to your "startup applications" menu.

I did, and it works.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.