Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

where can I download this package? I've found it in hardy, but it seems to be unavailable.

I'm trying to install dbmail from :

thufir@dur:~$ sudo aptitude install dbmail -v
The following NEW packages will be installed:
The following packages are SUGGESTED but will NOT be installed:
  dbmail-mysql dbmail-pgsql 
0 packages upgraded, 1 newly installed, 0 to remove and 5 not upgraded.
Need to get 315 kB of archives. After unpacking 1,053 kB will be used.
The following packages have unmet dependencies:
  dbmail: Depends: libgmime-2.0-2a which is a virtual package.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     dbmail [Not Installed]                             

Accept this solution? [Y/n/q/?] Y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

Current status: 0 broken [+0], 5 updates [+0], 27 new [+0].
thufir@dur:~$ aptitude search libgmime
i   libgmime-2.4-2                        - MIME message parser and creator library - runtim
i   libgmime-2.4-dev                      - MIME message parser and creator library - develo
p   libgmime-2.4-doc                      - MIME message parser and creator library - docume
i   libgmime2.4-cil                       - CLI binding for the GMime library               
p   libgmime2.4-cil-dev                   - CLI binding for the GMime library               
thufir@dur:~$ tail /etc/apt/sources.list

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb oneiric main
# deb-src oneiric main
deb oneiric multiverse restricted universe main

deb unstable main

I upgraded to 12.04

share|improve this question

1 Answer 1

You likely won't find a PPA with such an old version of libgmime for a new release (the current version appears to be 2.6 (libgmime-2.6-0)). Possible solutions include:

  1. Contact the upstream developer of the software and see if a newer version would work instead.
  2. Compile the libgmime version you need from source.
  3. Install the Natty version of libgmime-2.0-2a
share|improve this answer
it's a dependency for dbmail. There's no repo? – Thufir Aug 14 '12 at 17:02
Looks like dbmail was dropped in Oneiric, probably because it doesn't support a newer version of libgmime (I didn't look too much into this). I've updated my answer with another possibility. – tgm4883 Aug 14 '12 at 19:14
can you perhaps explain how to install something from natty? I upgraded to 12.04 – Thufir Aug 15 '12 at 1:35
You would have to manually download the package from… and install it with dpkg – tgm4883 Aug 15 '12 at 13:17
I'm tired, admittedly, but when I look at the packages I don't see libgmime-2.0.2a devel for i386..? I think I'm on a fools errand perhaps, where the thing I want to install seems to have amd64 requirements. – Thufir Aug 15 '12 at 18:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.