Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running the newest version of VirtualBox, 4.1.18-78361~Ubuntu~precise from the VirtualBox repository, on Ubuntu 12.04 with the Oracle VM VirtualBox Extension Pack.

When I go into Settings->USB for my virtual machine and click "Add Filter From Device" I get no devices in the list. Only a text saying "no devices available".

The device I'm trying to use in the Windows 7 x64 guest OS is a SATA-to-USB controller that is present on my Ubuntu system. There is both this device and USB mouse connected to my Ubuntu PC, neither of which show up in VirtualBox (output from lsusb):

Bus 006 Device 002: ID 046d:c050 Logitech, Inc. RX 250 Optical Mouse
Bus 003 Device 002: ID 174c:55aa ASMedia Technology Inc

I've set up a USB device filter on the Settings->USB page for a device with Vendor ID 174c and Product ID 55aa. When I plug in the device, however, a prompt from Ubuntu pops up asking me to enter the password to decrypt the volume (the disk in the SATA-to-USB controller is encrypted using dmcrypt and set up with LUKS).

My user is a member of vboxusers:

rune@rune-desktop:~$ groups rune
rune : rune adm cdrom sudo dip plugdev lpadmin sambashare vboxusers samba

How do I get my Ubuntu 12.04 host OS to pass on the USB device to my Windows 7 guest OS?

EDIT: Output of ls -lR /dev/vboxusb/ as requested:

/dev/vboxusb/:
total 0
drwxr-x--- 2 root vboxusers 60 Aug 15 21:31 003
drwxr-x--- 2 root vboxusers 60 Aug 15 21:20 006

/dev/vboxusb/003:
total 0
crw-rw---- 1 root vboxusers 189, 257 Aug 15 21:31 002

/dev/vboxusb/006:
total 0
crw-rw---- 1 root vboxusers 189, 641 Aug 15 21:20 002

EDIT: Now it works :. I have no idea what I did (if anything) to make it work. But now all the devices show up, and the guest OS can use the device in question correctly.

share|improve this question

closed as too localized by Takkat, RolandiXor, hexafraction, LnxSlck, Jorge Castro Sep 26 '12 at 2:12

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
What's the output of ls -lR /dev/vboxusb/? –  Eric Carvalho Aug 14 '12 at 13:14
    
I've added the output of that command to the original post. –  runeks Aug 15 '12 at 19:37
    
Devices connected to USB 3.0 ports are not detected by VirtualBox (virtualbox.org/ticket/8873). Does it apply to you? –  Eric Carvalho Aug 16 '12 at 17:37
    
Well this is strange. Now the devices show up! I connected an additional USB device (a USB stick) to see if this would show up, and now all my USB devices show up! I'm not sure why. Maybe an Ubuntu update fixed the issue? Thanks for your help in any case! –  runeks Aug 18 '12 at 13:41
1  
Might have helped me... anyway, after freshly installing VirtualBox, /dev/vboxusb belongs to root:root, after a restart this is set to root:vboxusers. So, adding my user to group "vboxusers" and restarting the machine solved the issue for me. –  Nodebody May 19 '13 at 11:38

Browse other questions tagged or ask your own question.