Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

According to How to use Alt + GraveAccent on non-US keyboard?, the Unity shortcut to switch between windows of the same application is Alt + (whichever key is above Tab).

It doesn't work in my DELL-SK8115 keyboard with Brazilian ABNT2 layout. It's like the key is broken (i.e. pressing the combination has the same effect of pressing only Alt).

Also, if it helps, the same key (but in the Ctrl + ` combination) doesn't work in Sublime Text 2, either.

share|improve this question

2 Answers 2

To change the so-called Alt+` and Alt+Shift+`, which switch between multiple windows of one application, to any custom key combination:

  1. Click here to install the Compiz Settings Manager (CCSM) using the Software Center

    • Or install it from the terminal with sudo apt-get install compizconfig-settings-manager from the terminal
  2. Start it from the Dash or by typing ccsm from the terminal.

    Statutory Warning: Compiz Config Settings Manager is an advanced tool and one tiny mistake, typo or an accidental click of the mouse can leave your desktop unusable, requiring time and effort to fix it. Please be very careful and follow instructions...thanks. If you mess up, please see this answer on how to fix things.

  3. Type "Unity" in the filter box on the left, and click on the Ubuntu Unity Plugin:

    enter image description here

  4. Click on the Switcher Tab on top, and

    enter image description here

    • Look for the Key to flip through windows in the switcher entry near the bottom (scroll down if necessary)
    • Click on the Disabled button next to it
    • Check the Enabled box on the "Edit Key" popup
    • The keys will show, and click on the Grab key combination button
    • Press the keyboard shortcut combination you do want to use and this will appear beneath the box.
    • Click on OK, and this shortcut will now show in place of the Disabled button

    • The Alt+` is now remapped. To do the same for the reverse Alt+Shift+` shortcut, repeat step 4 for the Key to flip through windows in the switcher entry, or you can just leave it disabled.

Finally, close CCSM and if you no longer need it, please consider uninstalling it.

share|improve this answer
    
There's no "swicther" where it should be. I tried googling "switcher tab missing from ccsm", but nothing blatantly useful showed up. I also made sure I had the latest version installed from apt-get. I'm using 11.04, is this a problem? –  Rafael Almeida Aug 20 '12 at 21:39
    
@RafaelAlmeida: Yes, it is. This works on 12.04, it may on 11.10, and apparently does not on 11.04. Sorry, but you may have to upgrade to get this working. –  izx Aug 20 '12 at 22:30

in ubuntu 14.04 you also need to disable in ccsm->desktop wall->Bindings->Move within wall->Move next

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.