Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just reinstalled Ubuntu 12.04 and upgraded the kernel to 3.2.0.29. There is no audio--the sound card is not listed in lspci output:

00:00.0 Host bridge: Silicon Integrated Systems [SiS] SiS649 Host (rev 10)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media IO] LPC Controller (rev 36)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 IDE Controller (rev 01)
00:03.0 USB controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.2 USB controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 90)
00:05.0 IDE interface: Silicon Integrated Systems [SiS] RAID bus controller 180 SATA/PATA  [SiS] (rev 01)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV370 5B60 [Radeon X300 (PCIE)]
01:00.1 Display controller: Advanced Micro Devices [AMD] nee ATI RV370 [Radeon X300SE]

There are no proprietary drivers or anything on the system.

The thing is, this is the second time I installed Ubuntu 12.04, using the same LiveCD, and the first time, audio worked like a charm. I submitted a bug already, but is there anything I can do to get the OS to detect my sound card w/o reinstalling?

share|improve this question
    
Did you boot the same way, or did you change boot settings with F6? –  hexafraction Aug 14 '12 at 12:17
    
How did you update the kernel? –  green7 Aug 14 '12 at 12:52
add comment

1 Answer 1

Here are the modifications I can remember (all added after the install to fix various problems):

"nomodeset" and "b43.blacklist=yes" added to the grub file "FRAMEBUFFER=Y" added to /etc/initramfs-tools/initramfs.conf

I think I did have to check options acpi=off and nomodeset when I installed Ubuntu; the LiveCD wasn't booting in trial mode. (ETA: also possibly noapic. Brilliantly, I checked these not being entirely sure what they mean, but I was desperate)

share|improve this answer
    
I just used the GUI update function, it updated the kernel automatically. The installer includes 3.2.0-23, I think? Now it's 3.2.0-29. I actually don't think it's the kernel that's causing the problem, because audio was broken before the updates were installed. I was hoping the update would fix the audio issue, but it didn't change. –  bibbledy Aug 14 '12 at 13:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.