Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a csv file which contains English and Chinese words, in XP I could open it with Notepad++ and it displayed both without problem, but when I went to Ubuntu 12.04 using gedit, it showed Chinese char as bunch of garbage, what should I do to display correctly the Chinese char in csv file?

background: the csv file is an export file from Ant Movie Catalog, which contains movie titles in English & Chinese, so when I tried to export to .amc format and imported into GCStar, it showed Chinese titles as garbage, the same using XML export, when I tried to export to csv, it worked (the csv file showed Chinese char in XP), but when I tried to open it in Ubuntu 12.04 using gedit, it showed garbage as well, so I have to fix it first before importing into GCStar.

TIA Michael

share|improve this question

closed as off-topic by Seth Jun 23 at 23:43

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Seth
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Still looking for an answer? How about the one below? –  Seth Jun 23 at 23:43
add comment

1 Answer 1

Execute the following code in terminal.

gsettings set org.gnome.gedit.preferences.encodings auto-detected "['UTF-8', 'BIG5', 'BIG5-HKSCS', 'EUC-TW', 'CURRENT', 'ISO-8859-15', 'UTF-16']"

and the chinese will be displayed successfully. It works well with traditional Chinese on my 64 ubuntu 12.04.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.