Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is quite annoying. For some reason I can not hold anything with my mouse.

For example.

  1. I can not drag a window by holding its title bar.
  2. I can not move the scroll bar of any window by mouse.
  3. I can not even select text
  4. Alt+Click on a window does not move it.

All these tasks are related to dragging. And this dragging is not working. The problem steps are,

  1. Left click anything but dont release it
  2. Move the mouse now.

At this time it'll appear that you didn't left click earlier. So your mouse moves but no text is selected or not nothing is moved/dragged that you clicked earlier.

Update:

  1. This is a Logitech wireless mouse. I also restarted and unplugged the usb wireless receiver and plugged it again. problem remains.
  2. I haven't edited compiz settings. In fact use default settings. Never edited.

Before the problem arose, I had 3 video files opened with VLC player. 2 of them were playing at the same time.

share|improve this question
    
Are you able to click on buttons? Also, have you edited your Compiz settings? –  RolandiXor Aug 13 '12 at 22:39
    
Are you using a mouse, or a laptop touchpad? Have you tried using a (different) external mouse? –  InkBlend Aug 13 '12 at 22:40
    
What happens if you try to click and drag with your right mouse button instead? (If that does work, then your mouse buttons are reversed.) Also, does the problem still occur in a Unity 2D session (select "Ubuntu 2D" from the Ubuntu logo drop-down menu on the login screen; to get to the login screen, log out). The best way to provide this information is by editing your question. –  Eliah Kagan Aug 13 '12 at 22:48
    
@EliahKagan After changing the settings to right hand mouse I see the problem reduced a lot. Now I can take the window anywhere by dragging its title bar. Sometimes it slips. But it was never attached to mouse when I use left button. –  Shiplu Aug 14 '12 at 0:40
    
@Shiplu Is that to say that it was actually set to left-handed mouse before? Left-handed mouse means the right button is used for dragging. Is it set to right-handed mouse now? That means the left button is used for dragging. (To visualize--left-handed users typically put the mouse to the left of the keyboard, and right handed users typically put it to the right. It is the button closest to the keyboard that is used for normal clicking and for dragging.) Could you edit again for clarification--it's unclear to me if there's actually a problem, or if your mouse was just configured wrong. –  Eliah Kagan Aug 14 '12 at 4:52
show 2 more comments

1 Answer 1

up vote 2 down vote accepted

It seems to be a hardware problem. Try it with a nother mouse before starting debugging. You should even try changig batteries in you wireless mouse if you can. (In some models, lacking the wireless signal can be considered as don't pressing the button, even if you do so)

share|improve this answer
    
It was indeed a hardware problem. I fixed it myself –  Shiplu Aug 17 '12 at 21:53
    
@Shiplu You should accept this answer, then (or post your own answer detailing the nature of the hardware problem, if you prefer; if you post your own answer, you can accept it 2 days later). –  Eliah Kagan Aug 27 '12 at 4:46
    
@EliahKagan Thanks for notifying. I actually forgot. BTW I had to fix it myself which was a pure hardware failure and obviously not related to Ubuntu. So I didn't put it in answer. But wrote it in a comment :) –  Shiplu Aug 27 '12 at 13:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.