Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to get TwinView working but in the end all I got is this.

http://i.imgur.com/anzMT.png

On my way to TwinView I have modified /etc/X11/xorg.conf but right know it looks like this.

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 295.33  (buildd@zirconium)  Fri Mar 30 13:43:34 UTC 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AUO"
    HorizSync       30.0 - 75.0
    VertRefresh     60.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8600M GT"
EndSection

        Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP-0: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Seems like gnome thinks i have 5 screens connected, or something like that. Does anyone know how to remove the additional panels?

share|improve this question
    
Please tell us what version of Ubuntu you are running. Edit your question and add this information. –  RolandiXor Aug 13 '12 at 21:39
    
sorry, I'm running 12.04 –  roflmau Aug 13 '12 at 21:45

1 Answer 1

You didn't mention your Ubuntu version, but here is how to remove the panels:

11.04 and earlier:

  • Right click on the panel you want to remove and click "Delete This Panel".

11.10 and up:

  • Hold alt.
  • Right click on the panel and click "Delete This Panel".

As for Twinview, only use the official Nvidia tool to enable it.

Nvidia Settings

share|improve this answer
    
AWESOME, that worked well, I expected something like, "you have to go to /crypticFolder/crypticFolder/crypticFolder/crypticFile.conf and change the crypticValue to 42" Thanks a lot. Btw I used the NvidiaTool and this was the result of the "save xconf" Button, so I dug deeper. –  roflmau Aug 13 '12 at 21:53
    
@roflmau: I'm glad it worked for you. If it did, you can mark the question as solved by clicking the tick next to my answer. Your problem with so many monitors sounds like a bug as I don't see anything wrong with your config file. –  RolandiXor Aug 13 '12 at 22:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.