Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I often have to deal with documents using multiple images -- as e.g. Howtos, short documentations, or even books with many examples. Always when I start a new document with LibreOffice Writer and insert the first pictures, they are embedded by default. I need them to be linked by default -- but could not find a suitable setting. Can anybody tell me where that's hidden? I know it was possible with StarOffice 8, which I used before upgrading to Ubuntu 12.04.

In other words (to be clear from the beginning): How do I tell LibreOffice to always default to link inserted images instead of embedding them?

share|improve this question
1  
This isn't possible with LO right now, AFAIK, but it might be a good idea to ask here as well. I will gladly chime in if you choose to create a feature request on LO's bug tracker. –  Glutanimate Mar 25 '13 at 21:51
    
Unfortunately, that again requires a separate account. Neither do they provide the possibility to "anonymously" file a bug, nor permit using some existing like the ones we have here :( –  Izzy Mar 25 '13 at 22:04
    
I agree. It's annoying that each project has their own bug tracker and Q&A, but such is the reality in the open-source world. Unfortunately there's no way around that if you want your problem solved. I would file a bug report myself but I am very short on time right now and I am already maintaining too many reports. –  Glutanimate Mar 25 '13 at 22:19
1  
Not an answer, but a very quick workaround is using Ctrl-Shift-V, it will ask you HOW you want to paste the image. –  Gerhard Burger Mar 28 '13 at 12:54
1  
I cross-posted this question to AskLibreoffce and I advise everyone interested in this feature to vote for it. You will have to create a new account as AskLO doesn't use stackexchange, but wih OpenID this shoudn't be too much of a problem. –  Glutanimate Mar 29 '13 at 5:52
show 8 more comments

2 Answers 2

A bit strange, LibreOffice Writer Help said Link is default option:

Inserting Bitmaps

 1. Choose Insert - Picture - From File.

 2. Select the file. In the File type box you can restrict
    the selection to certain file types.  

 3. Click the Link box if you want a link to the original file.  
    If the Link box is marked, whenever the document is updated  
    and loaded the bitmap image is reloaded.

The editing steps that you have carried out in the local copy of the image in the document are re-applied and the image is displayed.

If the Link box is not marked, you are always working with the copy created when the graphic was first inserted.

To embed graphics that were first inserted as links, go to Edit - Links and click the Break Link button.

 4. Click Open to insert the image.  

The way around this workflow also related to using Gallery (just a bit faster way):

  1. Open Gallery pane.
  2. Create new "custom" theme.
  3. Add any pictures to newly created theme.
  4. Use Right Click on picture in Gallery to use menu Insert > Link.
share|improve this answer
2  
That is funny... It's certainly not the default option even if I check it.. –  Seth Mar 26 '13 at 0:40
    
:) really very strange program LibreOffice ... maybe you have unchecked "Always Ask" checkbox on the "Keep Link - Embed Bitmap" dialog ... so if your last way is Embed it is logically YOUR OWN defaults, not of LibreOffice ... –  swift Mar 26 '13 at 1:09
2  
I have to check that box every time I insert an image. Regardless of the last used state, this box always turns up unchecked in this dialog the next time you insert an image. –  Izzy Mar 26 '13 at 9:16
add comment

@manj_k over at AskLibreOffice was kind enough to let me repost his answer here:

Current state

As of this point there is no way of telling LO to link inserted images by default. But this enhancement has been requested, triaged and given a high priority on LO's bugtracker, so it's on its way:

Bug 61358 - UI: Remember state of option "Insert image from file -> Linked"

If you are interested in this feature and would like to follow its development I would advise you to subscribe to the bug report. Feel free to contribute and comment if you have any ideas on how you would like to see this option implemented.

Workaround

The Insert from File dialog isn't the only way to link a picture in a document. You can do so as well by dragging and dropping the image in question while holding down CTRL + SHIFT. Personally, I prefer this workflow as it's faster than the Insert dialog. Note: This only appears to be working with LO writer.

share|improve this answer
    
If I had two monitors, this would be a good work-around indeed! But at home, I only have one, and LO I use in full-screen mode (which makes drag-and-drop a little hard, but not impossible having the file manager open as a window to switch to with Alt-Tab, and then drag-n-drop). +1 from me meanwhile -- accept comes later (I doubt there will be a better solution). And thanks for crossing over to ALO and LO's bug reporting, I will follow-up there. –  Izzy Mar 29 '13 at 12:05
    
@Izzy Glad I could help :). As for your single monitor setup, how about this: Resize your file manager to a small enough size and set it to be always on top. Then move it to a corner of the screen where it's unobtrusive. Would this work for you? –  Glutanimate Mar 29 '13 at 12:21
1  
To make it take up even less space when unused, you can reactivate the roll up option. Here's a tutorial on how to do it. If you are using a different desktop environment this should be even less of a problem as most window managers (Openbox, XFWM, Kwin) support this option natively. –  Glutanimate Mar 29 '13 at 12:26
    
Thank you, MHC -- and yes, I could use the rollup-option (thanks for that idea I didn't think of). As described, having the FM in "window mode" and switching with Alt-Tab should do for me. I will try this when the next task comes up; currently I'm busy with other things, the books are just done :) –  Izzy Mar 29 '13 at 12:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.