Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I'm running an Ubuntu 12.04, I've configured "ssmtp" with my gmail account and now I'm getting every hour an email with a report, this is an example:

From: root <> Date: 2012/8/13 Subject: Cron <root@one> [
-x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -depth
-mindepth 1 -maxdepth 1 -type f -cmin
+$(/usr/lib/php5/maxlifetime) ! -execdir fuser -s {} 2>/dev/null \; -delete To: root

Failed loading /usr/lib/php5/20090626/ 
/usr/lib/php5/20090626/ cannot open shared object file: No
such file or directory

Some more info:

$ cat /etc/lsb-release


$ sudo crontab -l -u root
no crontab for root


$ nano /etc/crontab
# /etc/crontab: system-wide crontab
# Unlike any other crontab you don't have to run the `crontab'
# command to install the new version when you edit this file
# and files in /etc/cron.d. These files also have username fields,
# that none of the other crontabs do.

SHELL=/bin/sh PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin

# m h dom mon dow user  command
17 *    * * *   root    cd / && run-parts --report /etc/cron.hourly 
25 6    * * *   root    test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.daily ) 
47 6    * * 7   root    test -x /usr/sbin/anacron || ( cd / && run-parts
--report /etc/cron.weekly ) 
52 6    1 * *   root    test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.monthly )

I've commented the line 17 * * * * root cd / && run-parts --report /etc/cron.hourly, but the email still arriving.

share|improve this question

2 Answers 2

Just add below to /etc/crontab

share|improve this answer
It appears this line has to be added to every crontab file wanted silenced, (atleast from my testing). also beware that user crons live elsewhere: – ThorSummoner Aug 28 at 21:32

When cron starts a process, it captures any output that reaches stdout and stderr, and sends that in an email. To prevent these emails, you can re-direct the stdout and stderr, either to a logfile that you monitor, or /dev/null, if you don't care.

17 *    * * *   root    cd / && run-parts --report /etc/cron.hourly 2>&1 > /dev/null
share|improve this answer
Hi! Thanks for answer me so quickly! I've found this issue that I think is causing the problem: So, until the problem is resolved, I'm going to apply your solution! Thanks again! nonox – user83162 Aug 13 '12 at 20:47
I like this answer because it can disable mails for a specific job, rather than the MAILTO="" which would disable all cron mail. – mike Jan 27 at 5:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.