Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The Spotify indicator icon clashes with the native Unity theme, and is redundant, since it is already listed in the Sound indicator menu. Is there a way to remove or disable the Spotify indicator? Or at least to change the icon (couldn't grep it on my filesystem). I am using the Spotify "preview" with 12.04. Thanks!

share|improve this question
2  
Instead of removing it from your system, why not just make it look good and native in Ubuntu. While your at it why not just make Spotify look native in the interface as well via Ambiance? Sound hard? Well yes it massively freaking was! BUT I did it and you can use it if you want. :) michaeltunnell.com/blog/16-linux/… –  Michael Tunnell Jan 14 '13 at 9:40

3 Answers 3

up vote 4 down vote accepted

For Spotify version 0.8.8 and earlier

The best way to do this is to remove the icon used by spotify to display the indicator. This can be done by executing the following command in the terminal,

sudo mv /usr/share/spotify/theme/other/_linux/icon.ico /home/user_name/icon.ico

Replace user_name with your user name. This should effectively disable the spotify indicator. Exit spotify and restart spotify to notice the change.

For versions higher than 0.8.8

open up a terminal and open the zip file as root:

gksu file-roller /opt/spotify/spotify-client/Data/resources.zip

Then, inside the zip file, navigate to the _linux subfolder and delete the .ico files inside it. That's it.

share|improve this answer
    
This did work, for those looking at balloons's answer. –  Syzygy Nov 22 '12 at 19:27
1  
This doesn't work any more since Spotify 0.8.8.323... –  Syzygy Jan 7 '13 at 2:51
    
Alternatively you could simply rename the .ico file, in case you want to restore it later. I renamed mine "ico.disabled" –  Squishy Jan 30 at 0:41
    
Feel free to edit the answer and update it. –  nik90 Jan 30 at 14:49
    
I tried the second method (the one proposed by Kris) running Ubuntu 14.04 with Spotify client v.0.9.11.26 and now there's an uglier icon with a red circle in it. Seems the solution doesn't work any longer! –  Andrew C Jul 12 at 15:14

It could be worth trying to use apparmor to prevent spotify from loading the icon.

/etc/apparmor.d/usr.bin.spotify

/usr/bin/spotify {

  # deny read access to the icon
  deny /usr/share/spotify/theme/other/_linux/icon.ico r,
}

sudo /etc/init.d/apparmor reload

Wait for a few seconds and try running spotify again.

share|improve this answer
    
This didn't work for me, somehow. –  Syzygy Nov 22 '12 at 19:27

For more recent versions of Spotify the solution proposed by Nik no longer works. This is because the config files have been put inside a zip file, which is located at /opt/spotify/spotify-client/Data/resources.zip.

You could do essentially the same as Nik proposed. First, open up a terminal and open the zip file as root:

gksu file-roller /opt/spotify/spotify-client/Data/resources.zip

Then, inside the zip file, navigate to the _linux subfolder and delete the .ico files inside it. That's it.

share|improve this answer
    
Hey @Kris, I updated my original answer with your method. Just a thought, if my solution breaks, please feel free to edit and update it since it is better to have one solution which is correct than several answers. –  nik90 Dec 30 '13 at 13:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.