Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to buy minecraft and I decided first to go for the trial and see how it works. Installed oracle java and when I started the game it would always stuck at done loading. Deleted the bin folder in .minecraft, still the same issue. Deleted the .minecraft folder, still the same issue.

Has anyone experienced t;his issue on 12.04. Is there a way to fix it and enjoy the trial? Below is my java version

java -version java version "1.7.0_05" Java(TM) SE Runtime Environment (build 1.7.0_05-b05) Java HotSpot(TM) Server VM (build 23.1-b03, mixed mode)

Thanks in advance!

share|improve this question
    
Who spreads these false rumors that Oracle Java is needed? In fact, it may be the cause of problems. –  Oleh Prypin Aug 13 '12 at 16:22
    
You should not use the oracle java. The default java works fine. –  Alex L. Aug 13 '12 at 16:28
    
minecraft.net/download says 'also please use Sun's (i.e. Oracle's) JVM.'. The official Java performs WAY faster, all programmers know this. –  vemv Aug 16 '12 at 17:58

1 Answer 1

Try exiting Minecraft and re-launching it again. If it happens again, you will need to update the Lightweight Java Game Library files for Minecraft. To do that, do the following:

1) Download the latest version of LWJGL.

2) Extract the contents of the downloaded zip file.

3) Go into your Home folder and press Ctrl + H on your keyboard to view the hidden files and locate the .minecraft folder.

4) In the .minecraft folder, go to bin > natives folder. In that folder replace libjinput-linux.so, libjinput-linux64.so, liblwjgl.so, and liblwjgl64.so with the new files that you downloaded, which are located in the folder that was extracted from the downloaded zip file, native > linux.

5) Then in the .minecraft > bin folder, replace jinput.jar, lwjgl.jar, and lwjgl_util.jar with the files from the downloaded zip located in the jar folder.

share|improve this answer
    
Your answer make sense, but I cannot get it works... –  Rubens Mariuzzo Sep 4 '12 at 23:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.