Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using gnome 3 and gnome-shell (not gnome classic) on Ubuntu 12.04 LTS with emacs. I would like to use the keyboard shortcut Ctrl+Alt+D with emacs, however whenever I hit that keystroke, gnome intercepts it and hides all windows.

I have tried to disable it under Settings > Keyboard > Shortcuts > Navigation > Hide all normal windows. It appears disabled there, but if I hit Ctrl+Alt+D all windows will still minimize.

My next step was to try and use dconf-editor to disable it under org.gnome.desktop.wm.keybindings, but I couldn't find any option for "hide all windows" (or anything similar) there.

Any help would be appreciated, thanks.

share|improve this question
    
I can only add that I have the very same problem, but I don't know a solution. –  Marius Hofert Aug 19 '12 at 20:51
add comment

2 Answers 2

up vote 8 down vote accepted

I figured out that the following worked in my case. First, instead of trying to disable the shortcut, give it a new key combination. I did this in System Settings -> Keyboard Layout -> Layouts -> Options..., but it's a known bug that these settings are not respected in Gnome Shell.

Additionally, use dconf-editor to give it the same key combination:

  1. Open dconf-editor (Alt-F2, enter dconf-editor)
  2. Expand until the element: org → gnome → desktop → wm → keybindings.
  3. Change the value for the correct key (in your case, this should be show-desktop).

In my case, I wanted C-M-s be respected in Emacs, and not roll up the current window. So instead of trying to disable the shortcut by using brackets in dconf-editor, I gave toggle-shaded a new key combination: ['<Control><Super>s']. And suddenly, C-M-s was available in Emacs. Hope this helps for you, too.

share|improve this answer
1  
Thanks! That worked for me: setting org.gnome.desktop.wm.keybindings.show-desktop to ['<Control><Super>D']. –  cg505 Aug 20 '12 at 17:25
add comment

I just hit this problem on Ubuntu 12.04 LTS trying to unset the Ctrl+Alt+S binding for "toggle-shaded". AFAIK, I'm running the out-of-the-box window config: GNOME3, Compiz, Metacity, Unity.

Both Compiz and Metacity bind Ctrl+Alt+S, which REALLY threw me because I kept trying to edit the keybinding for compiz as a number of posts indicate (or rather org.gnome.desktop.wm.keybindings). But this changed nothing that I could see, even after restarting X.

In frustration I tried to edit the Metacity keybindings, which succeeded immediately (no need to restart unity, compiz or X.) Here's the command line:

gconftool-2 --unset /apps/metacity/window_keybindings/toggle_shaded

Check $HOME/.gconf/apps/metacity/window_keybindings/%gconf.xml for the changes.

I monitored changes to all files in my $HOME via man:find while trying the various config editors: gnome-control-center, ccsm, dconf-editor, gconftool-2 to see what changed.

dconf-editor worked well for compiz. My understanding is compiz and metacity work together to render the display but I don't know how. And I think there are a number of pluggable window managers that work with compiz, so that may further complicate the issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.