Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used eViacam in windows, but now I'm using (L)ubuntu 12.04, and I fail to install. I found a guide to install it on ubuntu 11.10, but I have unsolved dependencies.

Error runing "sudo apt-get install libcv2.1 libhighgui2.1 libwxbase2.8-0 libwxgtk2.8-0"

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libcv2.1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libhighgui2.1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libcv2.1' has no installation candidate
E: Package 'libhighgui2.1' has no installation candidate

LINK TO THE GUIDE

EDIT:

I've aded their repository, and updated. unsolved depencies again:

ergo@ikarusII:~$ sudo apt-get install eviacam
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Recommended packages:
  wx2.8-i18n
The following packages will be upgraded:
  eviacam
1 upgraded, 0 newly installed, 0 to remove and 88 not upgraded.
1 not fully installed or removed.
Need to get 5,235 kB of archives.
After this operation, 468 kB disk space will be freed.
Get:1 http://ppa.launchpad.net/cesar-crea-si/eviacam/ubuntu/ precise/main eviacam i386 1.5.4-0ubuntu1~precise [5,235 kB]
Fetched 5,235 kB in 18s (287 kB/s)                                             
dpkg: dependency problems prevent configuration of eviacam:
 eviacam depends on libcv2.1; however:
  Package libcv2.1 is not installed.
 eviacam depends on libhighgui2.1; however:
  Package libhighgui2.1 is not installed.
dpkg: error processing eviacam (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 eviacam
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question
add comment

1 Answer

libcv2.1 isn't available on Ubuntu 12.04 (according to packages.ubuntu.com it was replaced by libcv2.3). You'll need to contact the author of that PPA, which it seems the only way to do so is via their forum and ask if eViacam is compatible with libcv2.3 and if so, if they will update their packaging in the PPA to depend on that package rather than libcv2.1.

The same thing happened for libhighgui2.1 (it was replaced by libhighgui2.3) so you'll want to ask about it at the same time.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.