Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I first started using Ubuntu, only a German keyboard layout was setup in

System | Preferences | Keyboard

As the keyboard is actually a UK keyboard, I added a UK keyboard and removed the German keyboard. However, every time I log out, then back in again, the German keyboard is restored as the default (the UK keyboard is also available).

Is there a way that I can permanently remove the German keyboard, such that the UK keyboard is always used by default?

share|improve this question
    
What is you default locale? –  Mitch Aug 13 '12 at 13:30

3 Answers 3

Maybe the problem is in the login manager that still has the German keyboard layout.

To try and fix this, select the appropriate keyboard layout on the next login.

share|improve this answer
    
I can't see anything in the login screen that allows me to configure the keyboard layout –  Dónal Aug 13 '12 at 13:20
    
Are using lightdm or gdm as our login manager? –  LnxSlck Aug 13 '12 at 13:27

Search for System Settings in Dash or through Super+A and run it .Select the keyboard layout option as under the menu and Remove the German keyboard layout entry from here and try logout and login back. There is also a Keyboard layout option in Log-In screen , try to change it there too if this does not work.

enter image description here

share|improve this answer

Not sure how to remove keyboard layouts but the following will resolve the problem.

To change the keyboard to uk / gb layout use the following command in a terminal

setxkbmap gb  

This setting will be permanent and remain after logging out or re-booting.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.