Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The package system is broken

Check if you are using third party repositories. If so disable them, since they are a common source of problems.
Furthermore run the following command in a Terminal: apt-get install -f

Details :

The following packages have unmet dependencies:

gir1.2-mutter-3.0: gnome-shell: Depends: libgjs0-libmozjs185-1.0 but it is a virtual package

Depends: libpulse-mainloop-glib0 (>= 1:0.99.1) but 1:1.1-0ubuntu15.1 is installed

Depends: libpulse0 (>= 1:0.99.1) but 1:1.1-0ubuntu15.1 is installed

Depends: libxfixes3 (>= 1:5.0) but 1:5.0-4ubuntu4 is installed

             Depends: gnome-shell-common (= 3.5.4+git20120721.r1.dd80f390-0ubuntu1~12.04~ricotz1) but 3.5.4+git20120721.r1.dd80f390-0ubuntu1~12.04~ricotz1 is installed

libmutter0: Depends: libice6 (>= 1:1.0.0) but 2:1.0.7-2build1 is installed

Depends: libx11-6 (>= 2:1.4.99.1) but 2:1.4.99.1-0ubuntu2 is installed

Depends: libxcomposite1 (>= 1:0.3-1) but 1:0.4.3-2build1 is installed

Depends: libxdamage1 (>= 1:1.1) but 1:1.1.3-2build1 is installed

Depends: libxrandr2 (>= 2:1.2.99.3) but 2:1.3.2-2 is installed
share|improve this question
    
Are you using PPA's or an unstable release? –  hexafraction Aug 13 '12 at 12:34
    
It seems you are using gnome-shell installed from PPA ,you are Unstable gnome-shell version. And from which version are you Upgrading your Ubuntu. –  atenz Aug 13 '12 at 12:55
add comment

1 Answer 1

Open the file /etc/apt/sources.list and disable all the unstable or third-party repositories. Then run sudo apt-get update && sudo apt-get upgrade.

Also, as mentioned in the snippet you provided, you might have to run sudo apt-get install -f.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.