Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Here's what I have done:

sudo apt-get install vidalia

and it has been installed after that I've set the proxy settings in network to localhost:8118 and applied it system wide; however, when I want to install a package via apt-get an error logs saying: Unable to connect to localhost:8118: [IP: 127.0.0.1 8118]

Also tor check is not working because I can't connect to the internet at all when the proxy option is applied.

The main propose of using tor here is to use it with terminal.

Update: I've already applied the configuration to the polipo, FYI.

share|improve this question

1 Answer 1

In your question update you write that you applied the configuration to Polipo. Tor uses either Polipo or Privoxy. Privoxy is currently the default proxy and listens by default at port 8118.

Polipo listens at a different port. It uses 8123. So you should change your settings to 127.0.0.1:8123. If everything else is set up correctly it will work now.

share|improve this answer
    
Wrong answer. I have found the solution myself but that was a long time ago. I think they have completely fixed the issue by now. –  user1208478 Feb 27 '13 at 18:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.