Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I come to the ubuntu 12.04 lightdm login screen, I get several options for logging into desktop environments.

There is Unity and gnome and gnome-classic etc...

When I select unity, it logs me into Unity and

When I select gnome, it logs me into UNITY O_o

I also notice that even after selecting the gnome3 session , the icon on the login box is the same as the unity icon. I don't see the goofy gnome foot icon there.

One more IMPORTANT FACTOR

When I do "gnome-shell --replace" from inside of unity I get a perfectly wonderful gnome-shell environment.

This means that there must be something wrong with gnome-session or lightdm...

What should I do? I want to be able to select gnome3 from lightdm login screen and then login to gnome-shell like I should.


UPDATE 20120813 morning

I just used synaptic and reinstalled gnome-session and gnome-session-common and restarted and the icon problem is fixed but logging into gnome logs me into unity for some reason.


UPDATE 20120813 afternoon

I've narrowed the list of possible problems a little bit.

I created a new user and logged into gnome3 with no problems whatsoever....

So the problem must be user specific... It must be something in my home folder that is causing the problem ... correct?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

The problem seems to have been solved after I deleted several files under

~/.config/autostart

There were some files there from programs I had deleted in the past but the autostart was left over.

I also ran the Ubuntu Autostart utility and unchecked a ton of stuff that didn't exist anymore.

logout , login and problem solved.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.