Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a PowerBook G4 that was previously running Debian squeeze, and before that, OS X Leopard. It worked fine under Debian, but I disliked the GUI, so I decided to give Ubuntu a try.

I downloaded a copy of the PowerPC Desktop ISO, but the GUI was messed up: most of the screen was taken up by a large white rectangle, which was presumably supposed to be a window, but didn't load properly. Nothing happened when I clicked on the menus at the top, except for the one in the top-right corner that has shutdown options. I tried to restart it using that, but I didn't get a dialog or anything, so I finally ended up using control-command-power to force a reboot.

I then tried the alternate ISO to see if I could just use the textual installer. That worked, and I don't remember having any problems with the login screen, but after that, I had the same problems as with the live disc. I had no problems using the tty's, though, which is mostly what I did under Debian.

I later found that if you want full-disk encryption, you must set it up at install time. So I rebooted to the alternate disc and wiped the entire hard disk again, choosing the entire hard disk with encrypted LVM option during partitioning. The installation completed successfully, but now when I try to boot, I get just a black screen after the yaboot menus, no password prompt or anything. How can I fix this?

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

Typing Linux nomodeset rather than simply Linux at the yaboot prompt (or just pressing return, which in my case defaults to Linux) worked for me.

Thanks to L3top from Freenode/#ubuntu for suggesting nomodeset.

share|improve this answer
    
(The graphics were even worse, but at least the tty's work…besides, that's a different question.) –  Blacklight Shining Aug 18 '12 at 18:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.