Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to configure all the hardware and make sure that everything is working on an Asus N56VM-S4060x. I've made some progress based on other answers, but there are still a number of things that aren't working.

From a fresh install I have done the following,

  • Installed kernel 3.5 (following these instructions, based on this answer
  • Installed asus-wmi (not sure if this is necessary though)
  • Installed asus-wmi V999.01
  • Installed bumblebee
  • Tried to compile the alx module for Ethernet (failed)

After I installed kernel 3.5 the touchpad right click worked. After installing the asus-wmi the fn keys worked, except for the brightness functions.

After I installed bumblebee the launcher no longer displays the icons, but still works if you click in the right place. The other change I saw was the the task switcher (alt-tab) was different, but does not display the expected image.

I tried to compile the alx driver but after following the instructions had this error,

make -C /lib/modules/3.5.0-9-generic/build M=/home/duncan/src/compat-wireless-2012-07-03-p modules
make[1]: Entering directory `/usr/src/linux-headers-3.5.0-9-generic'
scripts/ /home/duncan/src/compat-wireless-2012-07-03 p/drivers/net/ethernet/atheros/alx/Makefile: No such file or directory
make[4]: *** No rule to make target `/home/duncan/src/compat-wireless-2012-07-03-p/drivers/net/ethernet/atheros/alx/Makefile'.  Stop.
make[3]: *** [/home/duncan/src/compat-wireless-2012-07-03-p/drivers/net/ethernet/atheros/alx] Error 2
make[2]: *** [/home/duncan/src/compat-wireless-2012-07-03-p/drivers/net/ethernet/atheros] Error 2
make[1]: *** [_module_/home/duncan/src/compat-wireless-2012-07-03-p] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.5.0-9-generic'
make: *** [modules] Error 2

Some other things which are not quite right:

  • Right click area of the mouse pad can result in a left-click
  • Screen does not automatically dim when removing the power cord

So the questions:

  • How do I get the GeForce GT 630M to work correctly? (and how do I know if it is being used instead of the Intel graphics?)
  • How do I get the brightness keys to work?
  • Do I need a particular version of the alx module?
  • What else might I need that I am missing?
  • Does the asus-wmi provide all of the necessary power management features?
  • Is there a way to stop certain areas of the touchpad from being a left click? i.e. I want to prevent left-clicks when I am trying to right click
  • What do I need to install for more advanced power management?
share|improve this question

About your first question:

Bumblebee switches to use the Geforce card only if you manually tell it to do so. Start programs that you want to run with the Geforce card with: optirun program

You can test it with glxspheres vs. optirun glxspheres. See here.

It worked for me with Asus N76VM and Ubuntu 12.10. There also seems to be a user interface currently being developed for bumblebee that lets you configure which programs automatically start with the graphics card.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.