Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to write my own Jenkins plugin. I'm following the official instructions.

However, when I get to the part for actually building the plugin, I get a test failure:

Tests in error: 
  initializationError(InjectedTest): com.sun.jna.Native.open(Ljava/lang/String;)J
$ mvn -version
Apache Maven 3.0.4
Maven home: /usr/share/maven
Java version: 1.6.0_24, vendor: Sun Microsystems Inc.
Java home: /usr/lib/jvm/java-6-openjdk-amd64/jre
Default locale: en_GB, platform encoding: UTF-8
OS name: "linux", version: "3.2.0-29-generic", arch: "amd64", family: "unix"

Which JDK do I need to have installed? Do I need to set any environment variables? How do I make it build properly?

I discovered that I didn't have libjna-posix-java installed, but I still get the same error after installation.

share|improve this question

closed as too localized by Jorge Castro, Marco Ceppi Aug 13 '12 at 17:50

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
sigh I just tried this in a fresh lxc environment and it worked fine. No idea what's going on in my main system. –  jml Aug 13 '12 at 17:39

Browse other questions tagged or ask your own question.