Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I want to install rawtherapee from Software Center, it will end with this message

install Archives() failed: (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 262697 files and directories currently installed.)
Unpacking rawtherapee (from .../rawtherapee_3.0.0~dfsg1-1build1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/rawtherapee_3.0.0~dfsg1-1build1_amd64.deb (--unpack):
 trying to overwrite '/usr/share/rawtherapee/images/curveType-NURBS.png', which is also in package rawtherapee-data 4.0.9-2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/rawtherapee_3.0.0~dfsg1-1build1_amd64.deb
Error in function: 

Can anyone help with this?

share|improve this question
    
What is the png file it is trying to overwrite. Have you put that there? If so, have you tried moving it elsewhere? If you did not put it there, have you tried to install rawtherapee before? –  Joe Tait Aug 12 '12 at 15:42
    
Are you running Ubuntu 12.04 or Quantal? –  user76204 Aug 12 '12 at 17:49
add comment

1 Answer

The file /usr/share/rawtherapee/images/curveType-NURBS.png is part of the default rawtherapee version in the repositories for ubuntu 12.04 (rawtherapee_3.0.0~dfsg1-1build1_amd64.deb in your case); and yet you also seem to have available rawtherapee-data 4.0.9-2, which is part of the Ubuntu 12.10 Quantal rawtherapee version as noted here. Therefore you seem to have available two incompatible versions of the program, which will try to replace each other, hence the install errors.

This is a problem that can occur with dpkg, and it is documented here in detail.

Firstly, try:

sudo apt-get -f install

If this is unsuccessful, the following commands should sort it out:

sudo dpkg -i --force-overwrite /var/cache/apt/archives/rawtherapee_3.0.0~dfsg1-1build1_amd64.deb  
sudo apt-get -f install
share|improve this answer
    
It is working!Thank you very much :) –  stofanko Aug 18 '12 at 6:08
    
Great! I should mark it as solved! –  user76204 Aug 18 '12 at 9:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.