Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Pity that gnome-shell's launcher shows only a few characters of the application's name. That's why I'd like to rename e.g. "web-browser firefox" into just "firefox".

Previous versions of gnome had a working Alacarte program which allowed to do what I need.
Now Alacarte shows this error while trying to enter the applications preferences:

File "/usr/share/alacarte/Alacarte/MainWindow.py", line 391, in on_edit_properties_activate
    process = subprocess.Popen(['gnome-desktop-item-edit', file_path], env=os.environ)
File "/usr/lib/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
File "/usr/lib/python2.7/subprocess.py", line 1249, in _execute_child
    raise child_exception

How do I rename an application without alacarte?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

In Ubuntu, apps are described in .desktop files

Gnome Shell, Unity, KDE Plasma, etc use those files to obtain application name.

They do so by looking up on Name parameter in .desktop file.

Most .desktop files are located in /usr/share/applications

So to change an application's display name :

  1. Open gedit and open /usr/share/applications/firefox.desktop from gedit // maybe it is firefox-broswer.desktop (not using ubuntu at the moment)
  2. Locate the Name=Firefox Web Browser line and change it to Name=Firefox
  3. Save the file and reload your shell

NOTE: You must open gedit as root :

gksu gedit
share|improve this answer
    
but alacarte doesn't ask for root password when modifies the launcher. There should be another way. –  user73331 Aug 13 '12 at 11:44
    
There are some .desktop files in ~/.local/share/applications. I do not know of any other way. Your best bet would be to ask alacarte developers how they achieved that without sudo. –  Aleksandar Aug 13 '12 at 12:53
    
ok, I just copied several .desktop files I wanted to change from /usr/share/applications to ~/.local/share/applications and changed. The files in home directory have the priority and now they show up in the menu as I want. Thanks. –  user73331 Aug 17 '12 at 16:44
    
You are welcome. –  Aleksandar Aug 18 '12 at 7:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.