Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 12.04 with default install of Unity.

The workspace switcher icon could have been better. The function it does is accomplished by a keystroke. The icon remains the same (two windows on Desktop 1) whether there are windows on other desktops.

Is there a better workspace switcher - one that represents windows on desktops in real time?

Alternatively, can I, and how can I turn the Workspace Switcher icon off?

share|improve this question

6 Answers 6

I dont know another icon but you can turn it off. Install compiz config settings from software center, install it and open it.

On the left choose general then general options goto desktop size tab and set all options to 1.

Then just wait for compiz to restart and it will be gone.

share|improve this answer
    
That will make number of desktops = 1. I need to have multiple desktops! –  deshmukh Aug 13 '12 at 12:03

To remove workspace switcher icon form Unity launcher.

  • Install CompizConfig Settings Manager

    sudo apt-get install compizconfig-settings-manager
    
  • Open Unity dash > type "compiz" > run "CompizConfig Settings Manager"

    • on the right panel click on Ubuntu Unity Plugin (it is in the Desktop group)
    • switch to third tab - "Experimental"
    • and uncheck "Show 'Expo Icon' in the launcher"
share|improve this answer
1  
Well, installed CompizConfig Settings Manager. But there is no option "Show 'Expo Icon' in the launcher" in the Experimental tab in Ubuntu Unity Plugin in Desktop group :( –  deshmukh Aug 13 '12 at 12:03

Pawelki's answer regarding Compiz might work. There is no official 'Dynamic' workspace Switcher icon.

You can change the number of workspaces using Compiz or MyUnity or Ubuntu Tweak. Gnome 3 allows dynamic number of workspace which you might like, though Unity is great.

share|improve this answer
2  
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  user61928 Oct 2 '12 at 8:27
1  
@IshaanDube Can you edit this answer to explain how to do this with MyUnity and Ubuntu Tweak? Right now, it might be quite hard for someone to use this answer. –  Eliah Kagan Oct 2 '12 at 11:40

An alternate workspace switcher? I don't know exactly what is wrong with the current one. I personally find it a ton more useful if you set expo to initiate upon moving your mouse to a corner, for me I have it set to the bottom right, and boom it goes to the workspace switcher (AKA expo) you can set that in the expo settings under the Compiz settings (CCSM)

If you want something more minimal like what existed in 10.04 you can try this: enter image description here

You can install that by running these codes in terminal:

sudo add-apt-repository ppa:geod/ppa-geod
sudo apt-get update
sudo apt-get install indicator-workspaces

Then run the program from the Unity dash by searching "work spaces indicator" and if you wish you could simply follow the instructions listed by others to disable the switcher Icon. Although it says it is for 11.04 you should have no problems using it in 12.04.


I got the latter information from this website: http://www.techdrivein.com/2011/05/10-useful-application-indicators-for.html

share|improve this answer
    
Workspace switcher is very useful. If you read carefully, I was asking about the Icon :) –  deshmukh Oct 7 '12 at 7:54
    
So you just don't like the icon? –  Weylin Schreck Oct 7 '12 at 8:00
    
Absolutely. It does not give any additional information and what it does can be achieved using keyboard -- much faster. In fact, I also will like to get rid of the Ubuntu icon at the top of the launcher. –  deshmukh Oct 7 '12 at 8:25
    
Yeah I know what you mean, pretty much useless if you would rather keep your hands on the keyboard, its even more useless if you have launcher on auto hide...like me. I have my initiate expo key set to grave key or the ~ key. And I also have a desktop edge if i'm just being lazy and and primarily using my mouse. I know you can eliminate the workspace switcher icon but I don't believe you can get rid of the Dash button. while you can simply open it by hitting the super key it still is useful to actually have the button there, I think. –  Weylin Schreck Oct 7 '12 at 8:53

Install Synaptic in terminal: sudo apt-get install synaptic and there install package "docky." Startup Docky in Unity-menu and now it is in bottom of display.

In preferences of Docky select workspace switcher and hide it automatically.

share|improve this answer

I had the same question as you because I am working on a small laptop with limited screen real estate, and I configured my touchpad to perform all of my workspace switching. I found out how to remove the icon, and it is not too involved. Please note that I am using 12.10, and this may not apply to 12.04. I am still a novice programmer and linux user, so please excuse me if I misuse any terms. Since the workspace-switcher-icon AKA the expo icon is "baked into Unity", you have to get the source code, alter it, and recompile it. The procedure is very similar to the one mentioned here:

How can I disable arbitrary default multitouch gestures in Unity?

Here is the procedure:

In terminal, enter these commands:

$ sudo apt-get build-dep unity    
$ cd /tmp
$ mkdir unity
$ cd unity

I used the tmp directory, but you could do it elsewhere.

Get the Unity source code:

$ apt-get source unity

Go to the directory "unity-6.12.0":

$ cd unity-6.12.0

Use your text editor of choice to open "LauncherController.cpp"

$ gedit /tmp/unity/unity-6.12.0/launcher/LauncherController.cpp

Press Ctl+F and seach for "workspaces". On Line 627 there is a command

bool wp_enabled = (workspaces > 1);

Change the "1" to a higher number than the number of workspaces you wish to use. For instance, I want to use 3 workspaces so I changed my entry to look like this:

bool wp_enabled = (workspaces > 4);

Save and close the LauncherController.cpp file, and then build Unity:

$ dpkg-buildpackage -us -uc -nc

It will take a few minutes. Then install the modified Unity that you just built:

$ cd ..
$ sudo dpkg -i *deb

Once it's installed you logout and log back in. Then open CCSM, go to General>General Options>Desktop Size tab, and change your number of desktops to 1. You should see the Workspace Switcher icon disappear from the Launcher. Now you can change your number of desktops back to the number you want to use, and the Workspace Switcher icon should remain hidden. You might be able to reboot and accomplish the same result, this is just what I did. You're done!

share|improve this answer
    
Wow, first time I've seen an actual modify/build cycle and it's benefits. Awesome, thank you. –  aditya menon Aug 5 '13 at 18:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.