Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a new Dell Ubuntu pre-installed laptop. It came with 11.10 and I've just upgraded it to 12.04 (Precise).

Firefox has its homepage set to Yahoo search and the default search engine is Yahoo too. I want to change the home page and the default search engine. Every time I change this, the settings do not stick until the next time I start the browser again.

There don't seem to be any such settings that I can change in Edit->Preferences. (It does not stick until the next startup of the browser if I change the homepage in the Preferences/General tab).

share|improve this question
    
It's very odd that Yahoo! is the default search engine. I don't understand how that happened. –  user25656 Aug 12 '12 at 8:00
    
From the fix I found, it appears that Yahoo/Bing may be paying Dell to do this. –  donatello Aug 12 '12 at 8:10

3 Answers 3

Change the Home Page to about:home in Edit -> Preferences -> General. If you want the home page to some other website, you can change it likewise.

Firefox Preferences


To change the default search engine, Type about:config in the URL bar in Firefox. Accept the warning.

Change the value of browser.search.defaultenginename to Google. The capital letter on Google is important.

share|improve this answer
    
Thanks for the quick response, but both these settings get reset if I restart Firefox. –  donatello Aug 12 '12 at 7:50
    
Is there are way to change these settings globally, rather than for just my current profile? I suspect there must be some global settings that just keeps resetting these values. –  donatello Aug 12 '12 at 7:52
    
What extensions do you have installed? Add it to your question. –  IAMA Sockpuppet Aug 12 '12 at 7:53
    
@donatello Oh sure. Check in /etc/firefox/syspref.js and change the settings as you see. –  IAMA Sockpuppet Aug 12 '12 at 7:55
up vote 1 down vote accepted

I just found the fix. The Dell preinstalled Ubuntu comes with a package called yahoo-default-settings. This is a locally installed package and does not seem to be present in a repository (neither in Ubuntu official repository nor Dell partner repository).

Just uninstall the package. Then, one can change the defaults and it sticks till the next start of the browser.

share|improve this answer

In my case package was named yahoo-browser-defaults, so I had to

sudo dpkg --remove yahoo-browser-defaults

(inside this package there was /usr/share/xul-ext/ubufox/defaults/preferences/001yahoo-defaults-dell.js file and in general /usr/share/xul-ext/ubufox/defaults/preferences/ directory is the one to check in case of such problems)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.