Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If my computer is on without an network connection(e.g. the router is rebooted, the network cable is unplugged, etc), it won't connect at all until I fix the connection then reboot the computer. How can I make the network manager automatically connect to a new network?

EDIT: Here is the log file edited to only show Network Manager. It only show a couple hours as the file is somewhat repetitive.

share|improve this question
2  
By default, Network Manager should automatically attempt to connect when possible. If yours only works after rebooting, this sounds like a bug. –  ændrük Dec 14 '10 at 23:49
1  
Is this the same problem you asked about in this question? –  ændrük Dec 14 '10 at 23:58
    
@Aendruk: A bug in what? In the comments below his answer, Stefano Palazzo Told me to ask this question. That question asks why, this questions ask how to fix it. Just making sure I cover all bases before assuming it's a bug. –  John Dec 15 '10 at 0:16
1  
It seems like a bug, certainly. This question is to find out how to work around it, or if it's an issue of configuration. –  Stefano Palazzo Dec 15 '10 at 0:21
    
@John Possibly network-manager, nm-applet, or the network interface driver. In order to find out, it would help to know what items are listed in the "Wired Network" section of the menu that appears when you click the NetworkManager Applet, what driver is in use, whether shroff's suggestion works, and whether there are any error messages from NetworkManager in System ▸ Administration ▸ Log File Viewer ▸ daemon.log, for a start. –  ændrük Dec 15 '10 at 2:25
show 3 more comments

3 Answers 3

I think you can open your network manger, then open your normally chosen network connection. You then can put a click in the connect automatically, it's at the top.

share|improve this answer
add comment

I find that simply unplugging my ethernet cable and and plugging it in again works. It has to do with the device not pick up that the cable is connected.

I also use mii-tool

sudo mii-tool -v  
eth1: negotiated 1000baseT-FD flow-control, link ok  
  product info: vendor 00:07:32, model 17 rev 2  
  basic mode:   autonegotiation enabled  
  basic status: autonegotiation complete, link ok  
  capabilities: 1000baseT-HD 1000baseT-FD 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD  
  advertising:  1000baseT-FD 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control  
  link partner: 1000baseT-HD 1000baseT-FD 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control  

then
sudo mii-tool -R reset MII to poweron state
sudo mii-tool -r restart autonegotiation

share|improve this answer
add comment

For what its worth I noticed some WARN lines output in the syslog but I have exactly the same lines and do not have the same problem.

I always tell my son not to be afraid to ask stupid questions so here goes.. is the Network Applet - Edit Connections - Eth2 - Edit - "Connect Automatically" checked?

share|improve this answer
    
Yes it is. Remember this is an old question. I have not had to reboot my router since asking this so I don't know if this is still a problem. –  John Jun 22 '11 at 3:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.