Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed 12.04 alongside Windows 7 on my Dell XPS 15z. The model came with a cypress trackpad for Windows 7. After installing Ubuntu, I realized the trackpad was not working at all. I tried installing Synaptics Touchpad in Windows, still it didn't work in Ubuntu. I searched on the net for similar problems but neither of them worked for me.

Here's what I did:

  1. Edit the rc.local file to add the following lines in the file:

    sudo modprobe -r psmouse
    sudo modprobe psmouse proto-imps

    [Also tried proto-bare, proto-exps]

  2. Tried to uncheck "Disable Touchpad while Typing" under Mouse Settings, but I could see no touchpad tab under that.

The command xinput list showed no touchpad. So maybe the problem is that touchpad is not detected at all?

Please guide me through this problem. I am a first time Ubuntu user and don't have much knowledge about it.

Are there any specific Ubuntu drivers for making Touchpad work?

share|improve this question
    
both the trackpad's, synaptics and cypress, works perfectly fine on windows 7. –  Supertoniefy Aug 11 '12 at 7:26

1 Answer 1

Google up project Sputnik. It seems that a new driver has been released.

http://bartongeorge.net/2012/06/20/sputnik-update-touchpad-driver-now-available/

share|improve this answer

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

1  
Can you please add some detail to your answer? It's little more than a link to a third-party site, which means it may be deleted. –  Tom Brossman Oct 17 '12 at 18:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.