Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am rather sure that I set up hibernation correctly, and that the swap file I am using is being recognized and written to when I click hibernate. (/hibernate.img) In the corner of the screen, it says system snapshot, compression ratio, etc.

However, when I resume from hibernate, the top left corner reads "resuming from hibernate.img" but then the system just freezes. Every time.

Some of the tutorials mentioned using a specially compiled kernel, and I have not done this. The kernel is simply 3.2.0-25-generic.

I am using 12.04 64-bit. Any help would be great.

share|improve this question
    
Sadly, chances are that the error does not lie within your setup. Hibernation has been disabled by default in Ubuntu 12.04 because it was very prone to errors. I've never gotten it to work reliably on my system. –  FuzzyQ Aug 11 '12 at 13:28
    
It worked just fine with a swap partition. (when the two separate installations didn't conflict) –  user77275 Aug 12 '12 at 23:59
add comment

1 Answer

Do you really need a swap file? In Linux you usually make a swap partition. That is a partition solely dedicated to function as swap memory. If you installed Ubuntu on a blank disk, you should have one by default. If you chose your own partition layout and didn't make one, I suggest repartitioning to have one.

The only issue I have encountered with hibernation so far is that if the swap partition is smaller than your physical RAM, hibernate always fails. Is the image file larger than your RAM or not?

share|improve this answer
    
it is smaller about 50%, but i was told that due to compression, that wouldn't be a problem. also I have dual-ubuntu installations and having one swap partition between the two leads to unbelievable complications. –  user77275 Aug 11 '12 at 4:30
    
If you want to hibernate both, you might want to try 2 swap partitions. A default installation will enable both swap partitions, but you can manually disable a swap partition to prevent one installed OS to corrupt the other's. You have to edit /etc/fstab to edit which swap files are used. –  Neduz Aug 13 '12 at 15:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.