Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm at my wits end - after trying solid for the past week to get a working display driver on my new hand-built machine, I have had zero success. I've exhausted the forums, trying every possible combination I could find and still have had no luck. Can anyone please provide me with some insight? maybe that one little thing I'm missing? Here's the low down:

I have a Gigabyte Radeon HD 7950 video card running on an intel i5 / z77 motherboard with a clean install of Ubuntu 12.04 64-bit Desktop. Verified hardware as working in Windows. I have tried installing just about every version of the AMD Binary Driver, as I have read repeatedly that the Radeon HD 7000 series cards are not supported by the open source driver. I have tried using the fglrx driver provided by the Ubuntu repository, as well as the amd website *.run files of catalyst driver versions from 12.1 to 12.6. I have also tried compiling the driver and installing exactly as directed by the page

What is the correct way to install ATI Catalyst Video Drivers?

But I still get the same error, regardless of which driver I use. I have also tried the drivers with the boot argument "nomodeset" to no avail. I'm not 100% sure which error is really the culprit of the failure in my Xorg.0.log, the "fglrx: No Matching Device Section for Instance" (note - the hardware @ PCI 1:0:1 it is complaining about is the HDMI Audio Device!?) error, or the "xf86OpenConsole: setpgid failed: Operation not permitted" error. You can see the full log, xorg.conf and lsmod, lspci output at the shared google docs folder below.

https://docs.google.com/folder/d/0ByswzbhYOUqSZ1owd3ZDVjRxQ00/edit

Any suggestion at all is appreciated (give up and wait for Ubuntu 12.10? haha). Thanks.

share|improve this question
    
I guess the display is connected to the card and not the motherboard. Have you tried looking into the UEFI system menu and disabling the IGP or setting the external GPU as default? Another question: Did the IGP work? Which motherboard do you have? –  LiveWireBT Aug 11 '12 at 0:18
    
Thanks for asking LiveWire, the display is connected to the 7950 card and I have turned off every option possible dealing with the IGP in the BIOS. However, no matter what the IGP settings are, the output of 'lspci' still shows the intel ivy bridge graphics controller... is this my downfall? My motherboard is an Asus P8Z77-V. IGP works fine, I just can't get anything other than a command line from the Radeon card. –  Jason Aug 11 '12 at 1:57
add comment

1 Answer

up vote 1 down vote accepted

I have found the cause of the problem and now my graphics card works perfectly - with both VESA and AMD Proprietary Drivers. Livewire was correct- I dug into why the integrated graphics controller kept showing up in my lspci output. This is all clear now as shown by the line in my Xorg.0.log:

[ 2.710] (II) fglrx: intel VGA device detected, load intel driver

It seems this was all caused by a bug in my bios/firmware. Even though I had disabled all the settings related to the IGPU in the BIOS, the motherboard never "turned off" the IGPU - it was still allowed to present itself to the OS. By updating the BIOS / firmware on my Asus P8Z77-V Motherboard, the integrated graphics no longer appeared in the lspci output and is now completely disabled. After this, my graphics card even works with the VESA / fallback driver where it did not work at all before.

Anyone else experiencing this problem should have another trick to try - be sure all extra graphics cards are removed from your system and be sure your integrated graphics card is also disabled. You can verify this by running the command lspci | grep -i vga

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.