Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've searched for 5 days on the Internet for a solution to my problem, and I already did almost everything, and I still have no positive results.

I installed 12.04 LTS in VirtualBox. I'm using bridged mode in the VirtualBox network preferences. I use as a router a Routerboard 450, with no proxy, DHCP with static IP to my virtual Ubuntu, and I use OpenDNS IPs to resolve the host names.

I'm new to the Linux world, I've started this week and I really want to solve this big problem. I don't want just to leave Ubuntu and start with CentOS or Debian, etc.

I've already tried to reinstall Ubuntu, I've disabled selinux, purged network-manager and did the configuration manually.

I really don't remember what more I did.

I can ping Google, the IP of OpenDNS also, I've tried to use Google DNS, I've changed the resolv.conf.

Can someone help me?

** Solved, avast firewall was blocking my connection, I've solved it enabling the ICS option **

share|improve this question

closed as off-topic by Thomas W., falconer, Radu Rădeanu, mikewhatever, guntbert Jan 14 at 20:54

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Thomas W., falconer, Radu Rădeanu, mikewhatever, guntbert
If this question can be reworded to fit the rules in the help center, please edit the question.

    
You're running a Linux VM on Windows/OS X and you can't use the web browser in the VM? Why have you set the network interface to bridged mode. Are you trying to host a webserver or some other service in the VM? You don't need bridged networking for that, you just forward the necessary ports in the same dialogue (probably hidden as advanced) where you switched from NAT to bridged mode. Install a clean new Ubuntu VM, if you're running a webserver or the like in the VM and want to access it from the outside forward the corresponding ports. –  LiveWireBT Aug 11 '12 at 0:09
    
I Know in the NAT mode I can browse, but I really want to use my virtual machine direct with the bridge mode, u have the solution. –  André Faria Aug 11 '12 at 0:26
    
Why do you need the bridge mode? Mostly it's just complicated and confusing. If you want bridging, you need to set up your network on your Ubuntu host running VirtualBox. No need to have static address on your host. If you want to have a client in the VB running a public service, you need a static address on the VB client, not the VB host. And the VB host need to be set up using a linux bridge in /etc/network/interfaces. –  Anders Aug 11 '12 at 1:53

1 Answer 1

I assume you have a single uplink and have configured NAT on mikrotik properly.

ping proved that you have a working NAT. dig proved that your upstream DNS is also working.

But you haven't proved you have TCP connectivity between you VM and Google. try:

telnet google.com 80

This opens a TCP connection to port 80 on a google's web server. If you get something like:

Trying 173.194.33.34...
Connected to google.com.
Escape character is '^]'.

then you have a working TCP connection and the problem is not in your network config. check your browser.

If you get stuck at Trying 173.194.33.34..., your network is blocking. Since you have a bridged virtual network, use wireshark in your host machine to figure out what's blocking.

share|improve this answer
    
Thanks for everyone's help, the problem was the avast! firewall, I solved it activating the ICS mode on it's firewall. –  André Faria Nov 28 '12 at 8:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.