Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed 12.04 and my system works fine. But after updating packages with the update manager, problems occurred.

I can't activate the Nvidia drivers (Control Center -> Additional Drivers). When I try to activate them, I get a error:

Sorry, installation of this driver, failed.

The error indicates a log file, /var/log/jockey.log. I have seen:

WARNING: modinfo for module nvidia_current failed: ERROR: modinfo: could not find module nvidia_current

ERROR: XorgDriverHandler.enable(): package or module not installed, aborting

I have tried with 295.33 and 295.40. But it doesn't work.

I have tried to reconfigure xorg.conf, with a lot of parameters. But I haven't got that it works. And I have tried to create a monitors.xml on /config, with the correct resolution, but when I log, I get another error: resolution not compatible. But before the update, that config works fine.

share|improve this question

closed as too localized by Jorge Castro, Thomas W., Ringtail, fabricator4, hhlp Jan 7 '13 at 10:42

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

Please revert all the changes you made (probably just rename or move the files). Reinstall the Nvidia drivers as described in my previous answer. It just seems to be that the files corresponding to the package got corrupted, which may be caused by a system crash or file system driver error. Doing a clean reinstall of the package should fix that.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.