Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I setup VSFTPD on my Ubuntu server 12.04, it worked very good. Until I tried to change the permissions of the user so the user couldn't go in the / directory and only in the directories inside /home/user/public_html.

It could have to do something with the fact that I did this:

sudo chmod 700 -R /

I have a user, ftpUser and he is inside a group, ftpUsers. The permissions of /home/user/public_html are:

drwxrwxr-x 9 ftpUser ftpUsers 4096

My VSFTPD file looks like this:


And in /etc/vsftpd.userlist there is only one line: ftpUser

How do I solve this so I can login, it think it has to do something with permissions but I don't now what it is!?

share|improve this question
Is user ftpUser a local or a virtual user? And does he has a home dir? – OrangeTux Aug 10 '12 at 13:00
It's a local user, and the home dir is /home/user/public_html, but now I tried to reboot Ubuntu server and I cannot log in with any account... – tversteeg Aug 10 '12 at 13:01
And when you set chroot_local_user=NO? Just for checking it that is the problem. I think that it has to do with that. – OrangeTux Aug 10 '12 at 13:04
Then I still get the same error! – tversteeg Aug 10 '12 at 13:20

2 Answers 2

That error is generated because of Selinux. Please do the following actions:

[root@sun02 vsftpd]# getenforce
[root@sun02 vsftpd]# getsebool -a | grep ftp
allow_ftpd_anon_write –> off
allow_ftpd_full_access –> off
allow_ftpd_use_cifs –> off
allow_ftpd_use_nfs –> off
allow_tftp_anon_write –> off
ftp_home_dir –> on (change that to on in ur case this option is off)
ftpd_disable_trans –> off
ftpd_is_daemon –> on
httpd_enable_ftp_server –> off
tftpd_disable_trans –> off
[root@sun02 vsftpd]# setseboll -P ftp_home_dir on

This is all that u want to need.

Good Luck!

source: Copied and pasted from the above link. Credits to @Jaime M. of

share|improve this answer

protected by Community Sep 16 at 11:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.