Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi my question pertains to Grub2. I am running Ubuntu on a bunch of industrial PC's which are out of reach and hence cannot be connected using keyboard / mouse.

I have noticed when the OS does not fully boot and I unplug the power and power on again, the grub menu loads but there is no timeout on this particular instance of the GRUB menu. This is perfectly reasonable as this would generally require human intervention to decide if you want to boot into the recovery etc. hoever, I would like to override this and set a timeout and boot to the OS every time.

Any suggestions?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

If you add timeout=10 to /boot/grub/custom.cfg (creating the file if it doesn't already exist) then the menu will be displayed for 10 seconds every boot, regardless of any settings in /etc/default/grub or any failed boots. If you do this, you should also add a comment explaining this to /etc/default/grub so that the next person that tries to change the timeout (which is normally done by editing /etc/default/grub) will know that the setting has been overridden in /boot/grub/custom.cfg.

share|improve this answer
    
Perfect. Worked like a charm. Thanks. –  cyberjar09 Aug 13 '12 at 0:04
    
You're welcome. –  Jordan Uggla Aug 13 '12 at 2:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.