Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Inserted DVD disc not recognized

I'm running ubuntu 12.04, I put a music cd in the dvd player and it plays it. I put a dvd to watch a movie and nothing happens. I have vlc and movie player installed. It's like ubuntu does not see the dvd player. can I get help please.

share|improve this question

marked as duplicate by Eliah Kagan, Jorge Castro, con-f-use, Marco Ceppi Aug 20 '12 at 14:54

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

2 Answers 2

You may not have the proper codecs to play encrypted DVDs. all you need if this is your problem is to install them its called libdvdcss2. Here is a link to set it up just click on the 32-bit or 64-bit depending on your system, and it will open up ubuntu software center just hit install and try your DVD again.

http://www.omgubuntu.co.uk/2011/06/how-to-enable-dvd-playback-in-ubuntu-11-04

share|improve this answer
    
thank you for your answer. I forgot to mention that it was not an encrypted dvd, however I click that link you suggested, and I was told that a newer version was already installed. When I go to "home", I see an icon for a hard disk but I don't see an icon for the dvd player. Could that be the problem? Thank you again –  rey Aug 11 '12 at 2:19
    
Try opening VLC player, and at the top left click media look for open disc click it, a new small window will open make sure DVD is selected and and in Device Selection it says /dev/dvd. Once that’s done click play at the lower right of the smaller window your DVD should play.IF it does work. to avoid all of this in the future open up system settings click on details at the bottom left then click Removable Media next to DVD should be a drop down bar click it and select VLC player. from that point on when you insert a DVD VLC player will open automatically and Play your DVD –  tom Aug 14 '12 at 0:18
add comment

Open Ubuntu software centre - search for codecs - it should find "ubuntu restricted extras" - Select - install you should be OK. Read the synopsis bellow from Ubuntu software centre - Good Luck

This package depends on some commonly used packages in the Ubuntu multiverse repository. Installing this package will pull in support for MP3 playback and decoding, support for various other audio formats (GStreamer plug-ins), Microsoft fonts, Java runtime environment, Flash plug-in, LAME (to create compressed audio files), and DVD playback. Please note that this does not install libdvdcss2, and will not let you play encrypted DVDs. For more information, see https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs Please also note that packages from multiverse are restricted by copyright or legal issues in some countries. See http://www.ubuntu.com/ubuntu/licensing for more information.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.