Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use ubuntu 11.04.

My boost version:

  sam@sam:~/code/ros/pcl$ apt-cache  showpkg libboost-all-dev
  Package: libboost-all-dev
  Versions: 
  1.42.0.1ubuntu1 (/var/lib/apt/lists/tw.archive.ubuntu.com_ubuntu_dists_natty_universe_binary-amd64_Packages) (/var/lib/dpkg/status)
   Description Language: 
                   File: /var/lib/apt/lists/tw.archive.ubuntu.com_ubuntu_dists_natty_universe_binary-amd64_Packages
                    MD5: 72efad05a3c79394c125b79e1d4eb3a7


  Reverse Depends: 
    libvtk5-dev,libboost-all-dev
    libfeel++-dev,libboost-all-dev
  Dependencies: 
  1.42.0.1ubuntu1 - libboost-dev (0 (null)) libboost-date-time-dev (0 (null)) libboost-filesystem-dev (0 (null)) libboost-graph-dev (0 (null)) libboost-iostreams-dev (0 (null)) libboost-math-dev (0 (null)) libboost-program-options-dev (0 (null)) libboost-python-dev (0 (null)) libboost-regex-dev (0 (null)) libboost-serialization-dev (0 (null)) libboost-signals-dev (0 (null)) libboost-system-dev (0 (null)) libboost-test-dev (0 (null)) libboost-thread-dev (0 (null)) libboost-wave-dev (0 (null)) 
  Provides: 
  1.42.0.1ubuntu1 - 
  Reverse Provides: 
  sam@sam:~/code/ros/pcl$                                                       

How to upgrade boost to 1.44+ by using apt tools?

Thank you~


When I run apt-add-repository,it shows:

  sam@sam:~/code/ros/pcl$ sudo apt-add-repository ppa:timklingt/ppa
  Error reading https://launchpad.net/api/1.0/~timklingt/+archive/ppa: GnuTLS recv error (-9): A TLS packet with unexpected length was received.
  sam@sam:~/code/ros/pcl$       

How to fix it?

Thank you~


I try to install libboost1.46-all-dev:

  sam@sam:~/code/ros/pcl$ sudo apt-get install libboost1.46-all-dev
  Reading package lists... Done
  Building dependency tree       
  Reading state information... Done
  Some packages could not be installed. This may mean that you have
  requested an impossible situation or if you are using the unstable
  distribution that some required packages have not yet been created
  or been moved out of Incoming.
  The following information may help to resolve the situation:

  The following packages have unmet dependencies:
   libboost1.46-all-dev : Depends: libboost1.46-dev but it is not going to be installed
                          Depends: libboost-date-time1.46-dev but it is not going to be installed
                          Depends: libboost-filesystem1.46-dev but it is not going to be installed
                          Depends: libboost-graph1.46-dev but it is not going to be installed
                          Depends: libboost-iostreams1.46-dev but it is not going to be installed
                          Depends: libboost-math1.46-dev but it is not going to be installed
                          Depends: libboost-program-options1.46-dev but it is not going to be installed
                          Depends: libboost-python1.46-dev but it is not going to be installed
                          Depends: libboost-regex1.46-dev but it is not going to be installed
                          Depends: libboost-serialization1.46-dev but it is not going to be installed
                          Depends: libboost-signals1.46-dev but it is not going to be installed
                          Depends: libboost-system1.46-dev but it is not going to be installed
                          Depends: libboost-test1.46-dev but it is not going to be installed
                          Depends: libboost-thread1.46-dev but it is not going to be installed
                          Depends: libboost-wave1.46-dev but it is not going to be installed
  E: Broken packages
  sam@sam:~/code/ros/pcl$                               

What's these error means?

And how to solve it?

Thank you~

share|improve this question

1 Answer 1

Unfortunately, the latest official version of boost available in the repositories for Natty (11.04) is 1.42.

You can try installing it from an unofficial PPA, for example this one.

sudo apt-add-repository ppa:timklingt/ppa
sudo apt-get update
sudo apt-get install libboost1.46-all-dev
share|improve this answer
    
I have edited my original post. And also have apt-add-repository problem. How to fix it? Thank you~ –  sam Aug 10 '12 at 5:30
    
I found that I can run with 'sudo apt-add-repository ppa:tim-klingt/ppa'. But after I update, ubuntu still can't find libboost-dev-all. How to fix it? Thank you~ –  sam Aug 10 '12 at 5:36
    
Please try libboost1.46-all-dev package -- also edited answer. –  izx Aug 10 '12 at 5:38
    
I have edited my original post. And also have dependency errors. How to fix it? Thank you~ –  sam Aug 10 '12 at 5:45
1  
install first libboost1.46-dev, than libboost1.46-all-dev –  ulkas Nov 29 '13 at 3:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.