Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

brand new baby linux user here, never used Ubuntu or any other linux OS before, so be gentle and use short words!

I installed Ubuntu 12.04 on my new Acer Aspire One D270-F61C/KF netbook (it's a Japanese computer which had Japanese windows preinstalled, and I decided to take the plunge and try Ubuntu because English Windows costs the earth and stars). Wifi isn't working; I enter my wireless password, it tries to connect for a while, then asks for my password again. And KEEPS ASKING, every few minutes. Wired connection works fine.

Wireless card is a Broadcom BCM4313; I have the "additional drivers" checked and installed (I tried unchecking and then reinstalling them in case that would help, no joy, and now my home wifi connection isn't showing up in the list of available connections, argh). I've done a lot of googling and I gather there's a lot of issues with Broadcom cards, but some of the answers are for earlier ubuntu builds and many of them are a bit confusing for a new user. I gather I need to try installing some new drivers other than the proprietary ones provided, but I'm having trouble figuring out how that's done.

Anyone got some simple, step by step instructions for me? Please bear in mind, TOTAL N00B.

(EDIT): OKAY, got it fixed finally; after suggestions on the Ubuntu forums and messing around with drivers, what finally worked was installing Wicd. Not... using Wicd, for some reason, just installing it fixed it.


share|improve this question
Were you offered more than one choice of proprietary drivers? What is the one you have installed now? – Moshanator Aug 11 '12 at 4:58
I'm not sure what driver I have installed now, but I was never offered a choice, so far as I recall. In Additional Drivers it's listed as Broadcom STA wireless driver? But I think that's the package, rather than the specific one installed? Where would I look, or what terminal code would I enter, to find out for sure? – Dani Aug 12 '12 at 6:40
Broadcom STA is a specific driver, thanks. All Broadcom chips have an id that begins with "14e4:". Find out yours by entering "lspci -vnnd 14e4:" into the terminal. – Moshanator Aug 12 '12 at 8:16
It says: 02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01) Subsystem: Foxconn International, Inc. Device [105b:e042] Flags: bus master, fast devsel, latency 0, IRQ 17 Memory at 44000000 (64-bit, non-prefetchable) [size=16K] Capabilities: <access denied> Kernel driver in use: brcmsmac Kernel modules: wl, bcma, brcmsmac – Dani Aug 12 '12 at 10:44
Possible duplicate of Installing Broadcom Wireless Drivers – David Foerster May 21 at 18:09

I have acer laptop and using broadcom too, many story with it along ubuntu 12.04, imo there are something issue between the kernel and the proprietary drivers (I've tried with ubuntu 12.04.2 untill 12.04.5 with different experiences) The easiest method is try to install the newest ubuntu 14.04.

share|improve this answer

This will solve the problem:

sudo rfkill unblock wifi
share|improve this answer
I just checked rfkill list. It says wireless is neither soft nor hard blocked. – Dani Aug 12 '12 at 15:35
But, tried it ANYWAY, and it disabled my wireless completely. Fortunately it came back when I rebooted. Problem unchanged. – Dani Aug 12 '12 at 15:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.