Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an older 32-bit Belkin F5D6001 (aka ADMtek ADM8211 802.11b Wireless Network Card) that I got to work in 32-bit Ubuntu 12.04 via NDISWrapper (Windows Wireless Networking) by using the CD it originally came with and NDISWrapper (where it said hardware detected: Yes). Tried the same procedures in 64-bit 12.04 & even though it sees & communicates with the card, it will not connect to Internet.

It can see the networks around me but when I enter the 10-digit (xxxxxxxxxx) security key, it freezes the system. Did hard reset by powering down & removing plug & power btn for several seconds & restarted but same thing occurs. Spent countless hours researching on this & was wondering if there is a way to fool this 64-bit OS to accept the driver. I have tried countless cmds (iwconfig, ip addr, ndiswrapper related, etc.--you name it, I've tried it) and even though it can detect it, it keeps freezing.

I read that there is a default wireless card driver built-in to Ubuntu that may conflict & must be removed in order to prevent the freezing but I'm still a relative novice to Linux & am unsure where this driver is located so I can remove it. Even if I do find & remove it, I don't think it will solve it because this step was not required in the 32-bit OS which I stated above was successful. The chipset is ADM8211 with PCIID 1317:8201.

I've tried several drivers I found via SourceForge that indicate it's essentially the same chipset as Realtek 8180 even though its PCIID is different. Could only find "8180L" drivers on Realtek's website & placed them in Ndiswrapper. Tried them just in case along with ndiswrapper instructions listed here:

to change the PCIID to match the 8180's but to no avail even though was still able to see available networks. The only conclusions thus far I came to is: 1. that there is no way to make it connect to the web unless there is a way to fool the OS into believing it is a 64-bit capable card or something like that OR 2. the removal of aforementioned default ubuntu driver is definitely required with a 64-bit scenario like I am attempting. If anyone knows of a utility or method for this to occur, please feel free to help. Thank you and blessings.

share|improve this question
add comment

1 Answer

You can't run 32-bit kernel mode code with a 64-bit kernel.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.