Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the newest version of Oracle Java (1.7.0_05) from Webupd8's PPA.

Despite this, Google Chrome complaints that my Java plug-in is out dated, and forces me to confirm that I want to run every applet I have to use (like my bank and such).

Can anyone please tell me why this is?

Did Google screw up, or am I just in plain bad luck?

-- Edit -- (Upon request) I basically installed Java this way:

$ sudo add-apt-repository ppa:webupd8team/java
$ sudo apt-get update
$ sudo apt-get install oracle-java7-installer

This works excellent for Firefox, but Chrome complains about the version. I have tried OpenJDK 7, but it both reports being too old in Chrome, and furthermore it won't load it at all.

share|improve this question
    
Related: askubuntu.com/questions/173553/… –  Bruno Pereira Aug 9 '12 at 21:55
1  
+1, same issue here. –  Niloct Aug 10 '12 at 15:57
    
This bug is related to the plugin not loading: bugs.launchpad.net/ubuntu/+source/icedtea-web/+bug/1025553 –  beruic Aug 28 '12 at 23:47
    
add comment

3 Answers

Please try installing Oracle Java 7 the official way, i.e. downloading the binary installer from oracle.com instead of via a PPA.

AFAIK that definitely installs the updated browser plugin so that the browsers (at least Firefox for sure) can detect and use it.

share|improve this answer
1  
I think the PPA actually downloads the installer from Oracle and runs it automatically (at least that's what it advertises). webupd8.org/2011/09/how-to-install-oracle-java-7-jdk-in.html –  Ezequiel Muns Aug 10 '12 at 1:36
add comment

Could you please update your question and let us know what you did to install Java

I had a similar issue but I used the following command in Ubuntu Terminal

sudo apt-get install openjdk-7-jre

If you install this from Ubuntu's Software Center it will most likely install an add-on (icetea-netx). Make sure that it's selected before you hit install (in Ubuntu's Software Center). This will install Open Java 7 Runtime Environment with IceTea Netx (see http://icedtea.classpath.org/wiki/IcedTea-Web).

JDK is Java Development Kit and is not really required unless you are into developing Java programs.

share|improve this answer
    
Note that he installed Oracle Java so he probably does not want OpenJDK... –  izx Aug 9 '12 at 21:26
    
Yep I understand, Thanks for that izx, but my point is that this version worked on Chrome (for me) and I can use all the banking and other sites that require Java runtime. –  exIT Solutions Aug 9 '12 at 21:27
    
Updated the question above. I basically don't care too much whether using Oracle Java or OpenJDK, as long as Chrome just runs it instead of requiring me to permit it to run every time. Oh, btw I have a MSc in Computer Science, so just fire away with some command line ;) –  beruic Aug 28 '12 at 23:30
    
I know about JDK too btw. –  beruic Aug 29 '12 at 0:01
add comment

You may have one version on your system, but a certain browser could be using other.

You should point chrome to the right java version, point the location of your libpnpjp2.so to chrome plugins.

Something like this:

sudo ln -s /usr/lib/jvm/jdk1.7.0/jre/lib/amd64/libnpjp2.so /opt/google/chrome/plugins

share|improve this answer
    
Could you perhaps give me something usable on 12.04? The file libnpjp2.so isn't on my system. –  beruic Aug 28 '12 at 23:58
    
My Chrome installation didn't have the plugins folder... –  Keidax Aug 29 '12 at 0:23
    
Did you made a link to it? Like i posted above? –  LnxSlck Aug 29 '12 at 0:53
    
I can't make the link since the target doesn't exist. –  beruic Aug 29 '12 at 18:13
    
The target i gave you is an example. Have you tried locating libnpjp2.so in your pc? For example, sudo locate libnpjp2.so –  LnxSlck Aug 29 '12 at 22:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.