Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is the Error message I get -

The following packages have unmet dependencies:

skype-bin:i386: Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is installed
                Depends: libqt4-dbus (>= 4:4.5.3) but 4:4.8.1-0ubuntu4.2 is installed
                Depends: libqt4-network (>= 4:4.5.3) but 4:4.8.1-0ubuntu4.2 is installed
                Depends: libqt4-xml (>= 4:4.5.3) but 4:4.8.1-0ubuntu4.2 is installed
                Depends: libqtcore4 (>= 4:4.6.1) but 4:4.8.1-0ubuntu4.2 is installed
                Depends: libqtgui4 (>= 4:4.6.1) but 4:4.8.1-0ubuntu4.2 is installed
                Depends: libstdc++6 (>= 4.4.0) but 4.6.3-1ubuntu5 is installed

Software center will not allow me to install or uninstall any programs, update manager will not update anything. I have tried from Terminal to use 'apt-get' commands but I hit road blocks there too (as below) for any command I enter.

E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

Where do I turn next? How do I fix this?

Note: I could care less if I have to get rid of Skype, I rarely use it and have another computer it works on anyways.

share|improve this question
add comment

3 Answers

E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

For this problem , reason is simple . you must be root while doing this & to be a root , place sudo before the command you are typing . for example to update

sudo apt-get update

while coming to your first issue . open your terminal and type this

sudo apt-get install -f

hope that helps .

share|improve this answer
add comment

I suppose part of the answer is contained in the error message output by apt-get already: apt-get operations have to be called as root. So you should try sudo apt-get ..., which will ask you for your password and then execute as root (if your user privileges allow this).

In your case, if you don't care for skype anyway, try:

  sudo apt-get remove skype-bin
share|improve this answer
add comment

Your problem is, that you had Skype from Ubuntu installed in then from the website (or vice-versa). Remove Skype completely

sudo apt-get purge skype*

and then install the Skype version that you want to use.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.