Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a broadcom device using dell laptop that can dual boot into windows 7 and ubuntu 12.04 LTS. I have no trouble connecting to the internet using the Windows 7 side, but on Ubuntu firefox and chrome both hang on loading on startup for a bit and then give me the "webpage is not available" page with this error and some suggestions at the end:

The server at google.com can't be found, because the DNS
 lookup failed. DNS is the network service that translates a website's
 name to its internet access.

I can however use terminal and ping 8.8.8.8 successfully.

Oddly enough, when I'm on campus/ in my work building I can access the internet just fine through ubuntu and windows 7. Which leads me to believe it is some issue with my wireless router or my network configuration.

I have a LINKSYS WRT54GL. 1 other laptop and ipad that can successfully use wireless, a wired PC also connected to the router. My router setup uses DHCP with a cable modem.

I have tried using these commands related to DNS with no luck ;

/etc/init.d/dns-clean restart

/etc/init.d/networking force-reload

sudo /etc/init.d/dns-clean

Also for some additional perspective; I could use wireless just fine at home on the ubuntu side up until about 1-2 weeks ago when I started having this problem. I also use a VPN app to connect to my work's network. I can't recall doing anything differently from the past 1-2 weeks. The only changes I can remember are running the usual updates that Ubuntu prompts me with through update manager.

Any help would be much appreciated!

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The resolv.conf was probably changed for VPN use and was not changed back for normal use as a result of the crash. Deleting the old resolv.conf may help. You can make a backup copy of the file and delete the original with this single command:

sudo mv /etc/resolv.conf /etc/backup.resolv.conf

A new resolv.conf will be generated as and when needed. See the answer to the following question:

Internet connection not working although it says it is connected

Hope this helps

share|improve this answer
    
Thank you! It worked, however the file was named resolv.conf and not resolve.conf. Nonetheless thanks for the help, do you think this can be avoided as long as I always turn off the VPN before shutting down? –  Tenzin Aug 9 '12 at 17:47
    
You are welcome. I corrected the errors. Please mark the answer as accepted. This will close the issue and help others to find the right answer when they search for similar problem. –  user68186 Aug 9 '12 at 18:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.