Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to install the proprietary driver which is available for my graphics card. There are 2 available drivers;

"ATI/AMD proprietary FGLRX graphics driver (post-release updates)"


"ATI/AMD proprietary FGLRX graphics driver".

As the updates most likely were to improve something, I chose post-release updates version. However, when I click "Activate", the installation fails after download. The following message is shown to me:

Sorry, the installation of this driver failed.
Please have a look at the log file for details /var/log/jockey.log

Full jockey.log is available here:

Is there any way I could get this "post-release updates" working? Or should I try installing the older version?

share|improve this question
up vote 2 down vote accepted

I had the same problem, in my case reinstall command helped. Paste this in terminal:

sudo apt-get install fglrx-updates --reinstall

If it doesn't work uninstall FGLRX:

sudo sh /usr/share/ati/
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx

Then install driver using terminal:

sudo apt-get install fglrx-updates

If that doesn't work uninstall everything again and try using official script, just follow those commands:

cd /tmp && wget -O
chmod +x
sudo sh

Windows will popup and you can start installing drivers. When you finish type:

sudo aticonfig --initial -f

and reboot.

The link is for the ATI 12.8 64bit drivers, to get a newer version replace it with a link provided to you by official AMD site, just select your harware.

share|improve this answer
I tried that, restarted my computer and tried installing the update, because in "Additional Drivers" none of the drivers was active. The installation failed again: – Lassi Aug 10 '12 at 7:20
Maybe try to unistall FGLRX and then install it from the console: sudo sh /usr/share/ati/ sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx Reboot and do: sudo apt-get install fglrx-updates – Joseph Nobody Aug 13 '12 at 8:14

You just installed something (updates, some App from Software Center) at the moment the download of the driver package was complete and tried to install. Just try it again and make sure that there is nothing being installed at the same time ;)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.