Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I own an Acer AspireOne722

  • AMD C-60 APU
  • 2Gb RAM
  • HD6290
  • Conexant CX20588 sound card.

I use Ubuntu 12.04LTS
Output is perfect: both speakers and headphones work fine.
I have troubles with input: the internal mic was not enough powerful for skype calls so I tried to switch from "Internal Mic" to "Mic", realizing that the device called "Mic" (expected to be the 3.5mm mic port) is actually a loopback device: it gets audio stream directly from my output!!

Example: I play a song with my mp3player and I use gnome-sound-recorder with "Mic". I obtain to record the song played!!!

I tried to change alsa drivers from linuxant without improvements. Even Alsamixer seems not to solve: i think that the problem is located at lower layers of abstraction.

share|improve this question
    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  Seth Mar 20 '13 at 0:33
    
@Seth This is a bit new for being closed as abandoned, isn't it? Don't we usually wait 9 months? –  Eliah Kagan Mar 20 '13 at 5:49
    
@Eliah No. 4-5 was my understanding. –  Seth Mar 20 '13 at 14:06
add comment

closed as too localized by Seth, vasa1, Thomas W., Kevin Bowen, raaz Mar 20 '13 at 9:47

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

In the command prompt (terminal) try typing the following:

alsamixer

You may need to use sudo alsamixer (not sure, but if you notice your settings not being saved use sudo)

In alsamixer screen that comes up in the terminal, Press F6 and Select your sound card. Then using the Arrow keys go to MIC or Line In. Unmute both of them (Hit M to Mute or Un-Mute). Also try increasing the volume to full and test. I believe the jack on your lappy is called MIC but is most likely a Line-In as per the system, so just enable it too.

Update your question, if that worked for you.

share|improve this answer
    
I edited your question because new information and debugging of the problem should be edited into the questions themselves, not buried in comments. –  Jorge Castro Aug 9 '12 at 20:56
    
Oh. Cool didn't know it was that way...but that sound better –  exIT Solutions Aug 9 '12 at 20:58
    
Is it possible to delete that post that MikeMaz placed? the one in response to Comment if that worked for you... –  exIT Solutions Aug 9 '12 at 21:01
    
I've flagged it to be removed, and it seems he has 2 accounts so hopefully those will be merged too –  Jorge Castro Aug 9 '12 at 21:24
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.