Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I'm upgrading, get this error and can't install anything else

You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 krb5-multidev : Depends: libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.2) but 1.10+dfsg~beta1-2ubuntu0.3 is installed
                 Depends: libk5crypto3 (= 1.10+dfsg~beta1-2ubuntu0.2) but 1.10+dfsg~beta1-2ubuntu0.3 is installed
                 Depends: libgssapi-krb5-2 (= 1.10+dfsg~beta1-2ubuntu0.2) but 1.10+dfsg~beta1-2ubuntu0.3 is installed
                 Depends: libgssrpc4 (= 1.10+dfsg~beta1-2ubuntu0.2) but 1.10+dfsg~beta1-2ubuntu0.3 is installed
                 Depends: libkadm5srv-mit8 (= 1.10+dfsg~beta1-2ubuntu0.2) but 1.10+dfsg~beta1-2ubuntu0.3 is installed
                 Depends: libkadm5clnt-mit8 (= 1.10+dfsg~beta1-2ubuntu0.2) but 1.10+dfsg~beta1-2ubuntu0.3 is installed
E: Unmet dependencies. Try using -f.

I tried to run apt-get install -f but I still get the unmet dependencies error.

this is the apt-cache policy output : (i couldn't post it to much hyper links so i pastebin it)

apt-cache policy output

share|improve this question
    
Please edit your post to show the output of apt-cache policy –  jP_wanN Aug 9 '12 at 20:03
    
@jP_wanN thanks –  miki Aug 10 '12 at 8:10
    
It looks like the packages that are installed are newer than the ones that are being requested. –  xyious Aug 10 '12 at 8:42
    
You use repositories from lucid, oneiric and precise. That's probably what's causing your problem. Which Ubuntu version are you using? –  jP_wanN Aug 11 '12 at 9:31
    
@jP_wanN im using 12.04 –  miki Aug 13 '12 at 16:07

3 Answers 3

A security update for Kerberos packages was issued on July 31, 2012, to fix a security vulnerability. This bumped the Ubuntu version numbers from ubuntu0.2 to ubuntu0.3.

It's possible (but rare) that for a while, the libkrb5-dev/krb5-multidev packages were not updated, and thus had the old dependencies of ubuntu0.2 which was causing your problem.

In any case, it appears this has now been fixed:

$ apt-cache show libkrb5-dev | grep Depends
Depends: krb5-multidev (= 1.10+dfsg~beta1-2ubuntu0.3)
$ apt-cache show krb5-multidev | grep Depends Depends: libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.3), libk5crypto3 (= 1.10+dfsg~beta1-2ubuntu0.3), libgssapi-krb5-2 (= 1.10+dfsg~beta1-2ubuntu0.3), libgssrpc4 (= 1.10+dfsg~beta1-2ubuntu0.3), libkadm5srv-mit8 (= 1.10+dfsg~beta1-2ubuntu0.3), libkadm5clnt-mit8 (= 1.10+dfsg~beta1-2ubuntu0.3), comerr-dev

Please try a sudo apt-get update && sudo apt-get -f install to try to fix this. If it it doesn't, just remove the libkrb5-dev package. From a simulated removal on my dev system, it appears that the CUPS and QT dev packages may also be removed (libqt3-mt-dev, libcups2-dev). And then install libkrb5-dev again.

share|improve this answer

I would suggest attempting to remove the troublesome package before upgrading.

First, make sure removing krb5-multidev won't remove anything that appears to be vital.

sudo apt-get remove krb5-multidev --simulate

Review the packages under "The following packages will be REMOVED:". If you're not sure whether they are important, feel free to post the list here for us to look over for you.

Assuming nothing looks vital, go ahead and remove krb5-multidev:

sudo apt-get remove krb5-multidev

Then attempt the upgrade again. Once you've upgraded, you can reinstall krb5-multidev.

NOTE: There are probably more elegant methods to solve this problem. This is just an attempt to work around the error and get the upgrade done.

share|improve this answer
    
sudo apt-get remove krb5-multidev --simulate the output is Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: libkrb5-dev : Depends: krb5-multidev (= 1.10+dfsg~beta1-2ubuntu0.2) but it is not going to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). –  miki Aug 10 '12 at 15:44
    
Okay, I've got to admit, I'm a bit rusty on this sort of thing. If I were you, I'd try forcing the removal of any krb5 package that's being a problem (e.g. sudo apt-get remove libkrb5-dev --force). I would just be careful that no important packages accidentally went out the window with them. HOWEVER, you might want to hold out for a more elegant answer. –  mac9416 Aug 10 '12 at 18:34
up vote 1 down vote accepted

How I fixed it:

I went to the Synaptic package manager in order to fix the broken package. Click on Edit → Fix Broken packages.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.