Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 12.04 64-bit on my Asus K43SM Laptop with NVIDIA GeForce GT 630M. I am having trouble connecting another monitor (Samsung SMS19A100) as I don't know where to start the configuration. I have read about editing xorg.conf but I am still not familiar with it and it may be very risky. Need help. Thanks.

[EDIT] btw, I am planning to use TwinView, but I still need more details from the experienced. :P

share|improve this question
    
your laptop is optimus enabled isn't it? –  Web-E Aug 9 '12 at 15:47
    
yep. and for now, I am having a problem on configuring another display. –  edgar Aug 9 '12 at 15:58

2 Answers 2

up vote 0 down vote accepted

Your additional driver tab should not have any drivers available for the graphics card. Even if it is available, please don't install. Its because nvidia linux driver doesn't support optimus.

Please don't install nvidia drivers from nvidia site either. It will cause black screen/ distorted screen or lower graphics resolution.

You should install bumblebee.

Before proceeding installation I would suggest to read the discussions

How well do laptops with Nvidia Optimus work?

How well will Nvidia Optimus cards be supported in 12.04?

https://github.com/Bumblebee-Project/Bumblebee/wiki/FAQ

For multi moniter setup keep reading

https://github.com/Bumblebee-Project/Bumblebee/wiki/Multi-monitor-setup

share|improve this answer

If you have installed the nvidia drivers for your graphics card (use the Additional Drivers tool to install them if not) you should have a tool NVIDIA X Server Settings in your menu (nvidia-settings in the Terminal). This has lots of options, but you should only need the second entry (X Server Display Configuration) which has a graphical interface for setting up twin monitors.

Once you have the configuration you want, the Save to X Configuration File button (your password will be required) will make this configuration permanent (otherwise you'll be back to a single screen the next time you restart).

share|improve this answer
    
thanks! this is much appreciated –  edgar Aug 9 '12 at 15:28
    
If this answered your question, edgar, please mark chronitis's answer as correct! Thanks. :-) –  mac9416 Aug 9 '12 at 16:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.