Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am unable to mount and transfer photos from my Kodak C195 Digital Camera to my Laptop running Ubuntu 12.04.

Is there software that I need to download to get my camera to mount to my OS? I have tried using Rapid Photo Downloader and the original software that came with Ubuntu but nothing will allow me to view all and transfer all photos from my camera to Ubuntu.

share|improve this question

1 Answer 1

Before you try all the suggestions below, there is a useful note in the FAQ on gphoto.org that may suggest a quick solution:

3.3.2. I have a Kodak EasyShare™ camera, and gphoto2 can't detect it. What shall I do ?

Just press the button on the dock so that the USB device gets detected by the system and [then the] gphoto2 software can detect it.


Note: This answer may also be useful for anyone who has a similar problem mounting their camera and is not just applicable to this particular camera model.

Digital cameras are usually mounted automatically using libgphoto2 and are not mounted as usb storage devices; there is more information on the gphoto project here. There are several solutions to your problem:

1) Try to get the camera mounted; connect it and switch it on. Even 'unsupported' models can actually be mounted. By entering lsusb you can find the device and bus addresses:

Bus 001 Device 009: ID 040a:0565 Kodak, Inc.

and then manually mount it with gvfs-mount by specifying those usb bus and device addresses:

gvfs-mount gphoto2://[usb:001,009]

You could also create a script and make it executable and then run that script to mount your camera:

NOTE: I recommend to grep the vendor/product id string, as that is one of the unique identifiers; just grepping Kodak could identify other products or the wrong one.

You MUST replace the vendor/product string below with the correct one for your device, found with lsusb.

#!/bin/bash

val1="$(lsusb | grep -i "040a:0565" | awk '{print $2}')"
val2="$(lsusb | grep -i "040a:0565" | awk '{print $4}' | tr -d ':')"

gvfs-mount gphoto2://[usb:"$val1","$val2"]

exit 0

Now, use your file browser and click to show hidden files and your camera should be accessible from your .gvfs folder in your home folder. You should also be able to import photos by using applications such as gthumb.

Some cameras switch off after a while, so if this happens you will have to mount it again using the steps above.

Note: For Ubuntu 12.10 (and beyond) this ~/.gvfs folder is now: /run/user/username/gvfs.

2) The second option is simply to take the memory card out and put it in a card reader and then there will be no problems accessing it from your computer. I find this is often the best way if no other solutions work.

Also, the program you were using, Rapid Photo Downloader, does not detect digital cameras and is best used with a card-reader, as the developer notes on his site. So gthumb's (or Shotwell's) import facility is probably what you want to use; Shotwell's import facility even managed to import my pictures even when the camera was not mounted or available in the .gvfs folder because Shotwell always requires that a camera is unmounted anyway, unlike gthumb. So if you don't want to go through all the steps detailed in the first method everytime you connect your camera a workaround would be to use Shotwell to import your pictures (although you won't be able to browse them in your file browser or in the .gvfs folder).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.