Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I login, nothing happens.

I am presented with my desktop wallpaper.

Blank desktops suck

No Dash, no Launcher, nothing.

share|improve this question
IMHO this is a bug, but I have this since today. Could only find this bug bugs.launchpad.net/ubuntu/+source/unity/+bug/1212987 I followed the recommendations here: askubuntu.com/questions/17381/… Unity did reset but is not working OK, workspaces don't work, even if I enable or disable or change amount. No difference. Put plugin also crashes unity, –  Janghou Aug 16 '13 at 9:58
My problems started after switching from nouveau drivers to NVIDIA drivers (system settings / hardware tab). –  DanielaWaranie Dec 18 '14 at 12:35
i had this problem because my hard drive had filled up without my realising it. clearing up some space let me get into the desktop again. –  Nacht Dec 20 '14 at 7:36

25 Answers 25

up vote 176 down vote accepted

You just need to turn the Unity plugin back on. The problem is this is a pain in the bottom because you've now got no graphical method to do this. So:

  1. Change to tty1 by pressing Ctrl+Alt+F1 and log in.
  2. Install compizconfig-settings-manager by running

    sudo apt-get install compizconfig-settings-manager
  3. Then run it by doing this:

    export DISPLAY=:0

    The first part tells the terminal which display you want it to load on (otherwise it won't have a clue).

  4. Press Ctrl+Alt+F7 (or Ctrl+Alt+F8 sometimes) to get back to the graphical display where there should be a CompizConfig Settings Manager screen sitting there.

  5. Find the Unity plugin. Enable it.

  6. Everything should spring into life but if it doesn't, you might have to restart. You can do that by going back to tty1 and running sudo reboot.

share|improve this answer
(But none of the answers here got it back, nevertheless) –  Shahbaz Mar 11 '13 at 23:42
Worked perfectly well for me. As a side note, I did not need to enter the TTY terminal, was able to use the terminal shortcut (ctrl + alt + t). –  Tass Apr 24 '13 at 16:47
If you get to step 5 and don't see unity on the list, try this: sudo apt-get -f install && sudo apt-get --reinstall install unity –  Collinux Mar 18 '14 at 1:18
Had this problem myself but I'm unlucky with the solution far, doesn't work for me, still get the same empty screen on Ubuntu 14.04 LTS 64bit. Will go over the steps again to check if any thing was missed. Lenovo X201S Thinkpad i7 2.0Ghz 8Gb RAM. Never had this issue with 12.04 LTS –  therobyouknow May 19 '14 at 16:24
The fact that this is problem so common and long-lasting is, to me, rather disturbing. Does anyone know why this keeps happening, and what's causing it? –  InkBlend Nov 21 '14 at 22:38

For 12.10 and below:

Press Ctrl+Alt+T for a terminal and run ccsm, then re-enable your 'Unity' plugin.

You also may then need to run a unity --reset.

share|improve this answer
unity --reset is deprecated now and doesn't work. Is there a replacement? –  Shahbaz Mar 11 '13 at 23:41
@Shahbaz - unity --replace. –  nerof61 Apr 2 '13 at 14:48
@nerof61 also deprecated as of 13.04. See my answer below: askubuntu.com/a/286349/2638 –  Brandon Bertelsen Apr 27 '13 at 2:40
neither --reset nor --replace worked for me with my Ubuntu 12.04 ..running the commands instantly displayed unity-panel-service: no process found Backend : ini Integration : true Profile : default Adding plugins Initializing core options...done ...I waited and waited, and then I couldn't, interrupted with ctrl + c.. and now looking to try what other answers suggested.. –  precise Mar 20 '14 at 7:44

A solution good for me (has solved the same problem):

in a terminal:

sudo dconf reset -f /org/compiz/

and then

setsid unity

I hope it'll be useful.

share|improve this answer
Yep, works great with 13.10 too, greatly resets the buggy hud –  JB. Feb 8 '14 at 17:58
Fantastic. Works with Ubuntu Linux 13.04 Desktop in Parallels on Mac OS X. –  Elliot Jul 1 '14 at 6:47
Thanks! Works with Ubuntu 14.04 too. I wonder why this happened out of the blue though :-( –  Sadi Jul 30 '14 at 9:28
I needed export DISPLAY=:0 first. –  Uri Oct 6 '14 at 17:30
The first command did the trick for me. (Had to additionally export DISPLAY=:0 and set the DBUS_SESSION_BUS_ADDRESS variable as outlined in askubuntu.com/questions/457016/…) –  Janaka Bandara Nov 27 '14 at 1:00

In 13.04:

unity --replace is deprecated. Instead, use the following:

dconf reset -f /org/compiz/ 
unity --reset-icons &disown

Reboot if it doesn't work right away.

share|improve this answer
This worked for me after installing appropriate drivers for my Nvidia graphics card. See my answer askubuntu.com/questions/288235/… –  Thomas Arildsen May 2 '13 at 11:12
dconf reset command gives exitcode error 1 and won't work on 13.10. –  Peterdk Oct 24 '13 at 16:10
works when I ran at the second time dconf reset -f /org/compiz/ && unity --reset-icons &disown –  Claudio Santos Dec 17 '13 at 22:29
I'm again stuck at Initializing core options...done.. how long should I wait for this to complete?! –  precise Mar 20 '14 at 7:58
@rusty should be instantaneous. If none of these fixed your issue I would recommend opening a new question. –  Brandon Bertelsen Mar 20 '14 at 19:21

You might want to run the compizconfig-settings-manager Install compizconfig-settings-manager package and make sure that the Unity plugin is checked.

share|improve this answer

I have had exactly the same issue.

If you have Compiz Config Settings Manager installed it may be that the Unity Desktop Plugin is disabled.

Log in to a Unity 2D desktop and check that it is enabled in CCSM like this,


Unity Shell will not load in the default desktop if the tickbox is not checked and you will get the session in your picture.

share|improve this answer

Developers are always fixing bugs, so an alternative is to wait, and to follow progress on bug fixing (subscribe to Unity development in Launchpad).

  1. Press Ctrl+Alt+F2.

  2. Log in.

  3. Run sudo shutdown -r now in a terminal.

  4. At the login screen after your system restarts, choose Unity 2D (for now) by right-clicking the sprocket icon.

  5. Wait for a fix for Unity 3D/Ubuntu 11.10 (e.g. a week).

  6. Update your system to get the fix; in a terminal type sudo apt-get update && sudo apt-get upgrade.

UPDATE: I was able to resolve this by using ccsm, from Unity 2D login.

(This is adapted from this Ubuntu Forums post.)

  1. At the login screen, select Unity 2D and login.

  2. Install ccsm (CompizConfig Settings Manager) by running in a terminal: sudo apt-get install compizconfig-settings-manager compiz-fusion-plugins-extra.

  3. Start ccsm, and select the category Desktop. Enable the Ubuntu Unity Plugin; if asked to resolve conflicts, select the MIDDLE button for all conflicts. Close ccsm when done.

  4. Restart, select Unity (3D) and login.

share|improve this answer

The easiest way to do this is to press Ctrl+Alt+T to get a terminal and then issue:

rm -rf ~/.compiz-1 ~/.config/compiz-1

and your unity session will come back before your eyes..

This technique is better than re-launching ccsm, because you can get into OP's error condition without even accidentally de-selecting unity in ccsm; you can get it simply by accidentally pressing the "preferences" button in ccsm.

share|improve this answer
guess you mean .config/compiz-1 –  matteo Oct 13 '13 at 21:01
I cannot use ctrl-alt-T –  jimifiki Dec 18 '14 at 4:12
@jimifiki: press 'crtl' + 'alt' + 'f1' and then do what achiang suggested. though personally I'd move them out of the way incase you find more problems. –  isaaclw Dec 19 '14 at 19:40
@isaaclw I did what suggests. Nothing has changed. Remarkably the guest session works normally. –  jimifiki Dec 29 '14 at 15:05
I've seen this so often, and not every time I was able to solve it by just removing compiz configurations in the user's profile. Last time I wasn't able to even reinstall anything, as suggested on other comments, because even the network configuration was all screwed up. I issued an apt-get check and got a message stating that there was something broken up during a previous install or such, but with clear instructions on how to fix it (it was a dpkg <something> command I can't recall exactly now). –  Simón Jan 5 at 0:04

I had this problem too. I solved it with deleting the content of the ~/.config/compiz-1/compizconfig file and relog.

rm -rf ~/.config/compiz-1/compizconfig/*
share|improve this answer
+1, everything loaded right after i did this –  Casey Oct 31 '11 at 19:43
didn't work for me, pretty much as everything else on this page –  matteo Oct 13 '13 at 21:01

I have an Asus U36SD using an "Optimus" (Intel + Nvidia GPUs) set-up. I had Ubuntu 12.04 working just fine, but upgrading to 12.10, this problem appeared and persisted in 13.04. I have managed to fix it trough the following steps:

  1. Install Nvidia drivers from https://edge.launchpad.net/~xorg-edgers/+archive/ppa.


    I would really prefer the stable PPA at https://edge.launchpad.net/~ubuntu-x-swat/+archive/x-updates, but it does not seem to have packages for 13.04 yet. Update: these seem to be available as of Sep. 25. I would install this stable PPA - you can try but I have not tested it.

    The Ubuntu-supplied Nvidia drivers were already installed and I simply installed from this PPA by adding it and doing a package update using update-manager. UPDATE:

    sudo apt-add repository ppa:xorg-edgers/ppa

    (what I did) or:

    sudo apt-add repository ppa:ubuntu-x-swat/x-updates

    (stable release for 13.04 too now - not tested by me).

  2. Install Bumblebee from https://launchpad.net/~bumblebee/+archive/stable

    UPDATE: As of Oct. 6, ppa:xorg-edgers/ppa seems to contain bumblebee as well. So if you install from this PPA, you might want to try skipping the addition of the Bumblebee PPA and installing it from here instead.

    If you chose the stable PPA in step 1, install the Bumblebee stable PPA as follows:

    sudo apt-add-repository ppa:bumblebee/stable
  3. UPDATE: After adding the PPA(s), update your package lists:

    sudo apt-get update

    If you already had nvidia drivers installed from Ubuntu's standard repositories, simply upgrade to get the new version from the repository chosen in step 1.:

    sudo apt-get upgrade

    Install Bumblebee

    sudo apt-get install bumblebee
  4. Perform the following commands to 'repair' Unity (from brandon-bertelsen's answer to Unity doesn't load, no Launcher, no Dash appears):

    dconf reset -f /org/compiz/ 
    unity --reset-icons &disown
share|improve this answer
I just needed to perform the last step of your answer because I have the nvidia card deactivated in bios and never used it but the dconf reset worked perfectly. Thanks! –  Daniel May 7 '13 at 11:12
Thank you! This happened to me just now after an update and the last step was enough for me too. –  TenLeftFingers Jul 6 '13 at 1:15
how do you install that stuff from those links while having no launcher and being even unable to move windows around? I've tried skipping that step but it does not work for me. Can you give command-line instructions for adding those ppa's and installing those things? –  matteo Oct 13 '13 at 20:46
I added some details above - hope it helps. –  Thomas Arildsen Oct 14 '13 at 20:42

The original poster of the duplicate question, solved in editing his own question:

Solution found : Delete .Xauthority in my home (or rename it)

share|improve this answer

It seems there's a problem with 12.04 Unity 3D and the current Nvidia drivers.

See this post (Unity 3d no longer works after installing 12.04) for details of how to work round the problem.

I have a 32 bit Pentium 4 3.06 GHz Compaq D520SFF, with an Nvidia GeForce 6200, running kernel 3.2.0-24-generic-pae, and had exactly the same problem (2D works, 3D doesn't), and downgrading the Nvidia drivers got 3D working for me in a couple of minutes.

share|improve this answer
i did almost all the answers in this community related to my issue..please give me some thing work... –  Yahya May 1 '12 at 4:38
Almost all is a vague phrase.... Have you actually tried downgrading the NVidia drivers from 295.40 to 295.33 as described in the post? –  Heimdall May 1 '12 at 7:13
i did all described by the post nothing happened... –  Yahya May 1 '12 at 11:33

For the icons, it is due to Nautilus. Write nautilus & in a terminal, do not close it, and the icons will be back.

EDIT 10/10/2013: for Nautilus you can also type Alt + F2 to open Unity command line prompt and write nautilus in the global search/prompt CLI. A file explorer will open. You can close it if you want.

share|improve this answer

For 13.10:

Just to insure everything is installed:

sudo apt-get install --reinstall unity ubuntu-desktop

Next, reload everything:

dconf reset -f /org/compiz/ && unity --reset-icons &disown

I just tried this and it works!



If all else fails:

Remember, always make backups! However, sometimes a fresh install is good, reinstall Ubuntu?

share|improve this answer
The 'if all else fails' is a bit useless... see also: meta.askubuntu.com/questions/11710/… –  Wilf Aug 11 '14 at 20:29
@Wilf Fresh installs are never useless. Most people have a poor install or simply mess up their installation. Time for refresh. –  Jared Burrows Aug 11 '14 at 20:34
yeah, especially with upgrades... I have found that apt seems to have developed the knack of removing unity to to wacky interpretations for regular expressions (e.g. nuking webapps) - checking whether unity is installed/installing anything that is missing can then be helpful, –  Wilf Aug 11 '14 at 20:44

I had a similar problem:

unity with 14.04 in combination with IBM Notes9 resulted in some strange behavior (mouse clicks would stop working). My workaround for that was to open a terminal and restart unity by typing unity &.

The last time I did that, it totally corrupted unity - the no dash, no launcher no nothing. I think I tried EVERY suggestion that is listed on this page - none of it did help.

But a coworker finally had the answer that worked for me:
I installed the unity-tweak-tool; than I ran unity-tweak-tool --reset-unity and rebooted.

Afterwards, unity was back alive. Obviously all prior configuration changes to unity were gone, but that is what --reset-unity is about.

And the big advantage of this solution: it requires you to only add a single package and to redo your unity config changes - but you do not have to reset compiz, install ccsm, or follow all the other lengthy activities.

share|improve this answer
This is the only thing that worked for me! –  sevenseacat Jun 25 '14 at 13:33

I have had about 3 times where I needed the ctrl+alt+f1 to not loose work and it messed up... I have nvidia also. I would like to suggest this:

ctrl+alt+f1 (ok, blank screen) type your login, hit Enter, then password (all in blank screen) type this now:

sudo startx -- :1

will have to type password again and Enter this will open a X session at ctrl+alt+f8 (will jump to it automatically) now create a new empty text file called runBash.sh, and type on it:


save it, change its permissions to executable, and run it, you will get a truly relieving terminal that makes you remember why linux is good ! :D

after you finish, remember to ctrl+alt+f1, hit ctrl+c (will end the new X session), type exit, Enter, will end the terminal (blank screen) session. if you think you missed typing exit, just hit ctrl+c and type again, dont do it too fast...

so you can improve it, make a script to let you type as little as possible, but anyway you will still have to type a lot while the screen is blank, but it is better than nothing :)

still looking for definitive ctrl+alt+f1 proper solution ubuntu 12.04 + nvidia

share|improve this answer
hi again, I have ABSOLUTELY no idea why, but for some reason, after a system freeze (I was playing a 3D game in wine), I hard reset the computer, and from a sudden I have back my text terminal ctrl+alt+f1 (but my account become unable to login thru lightdm graphical login screen, despite I still can login thru text terminal, I continue this affair on this thread: askubuntu.com/questions/133733/…) –  Aquarius Power May 28 '12 at 1:33

If you hope into a tty (Ctrl+Alt+F1 through F6) and run:

DISPLAY=:0 unity --replace

It will reset Unity back on tty 7 (Ctrl+Alt++F7).

You can also try just:

DISPLAY=:0 unity

But that won't work if a windows manager is already running on display 0 (it will give you an error, just use unity --replace in that case).

If Unity absolutely refuses to restart try this:

Install gnome-panel:

sudo apt-get install gnome-panel

Than run it on display 0:

DISPLAY=:0 gnome-panel

You should then have Gnome 2 style panels on your desktop, which you can use to logout.

I find Unity to be really buggy on 13.04 with my Nvidia card.. YMMV.

share|improve this answer

It happens when you login with another tty and try, as the same user, to start X (with startx or initx) .

For example, Ubuntu runs in tty7. With CTRL-ALT-F1 tty1 opens. Log in as the same user, and run startx. Go back to tty7, logout and login. You only get the desktop wall paper.

To solve the problem, choose tty1, login, remove the .Xauthority file in your home directory, logout, login. Solved.

share|improve this answer
didn't work for me (also, I hadn't ever started X from another tty) –  matteo Oct 13 '13 at 20:53

If you use an acceleration graphics card alongside the default graphics card, it's possibly due to the installation of their drivers. A few updates of acceleration graphics cards drivers in systems that have two graphics card tend to present unstable behavior in some systems. I have an Nvidia card and an Intel card. It used to happen with me when I installed Nvidia drivers. Launcher and panel would disappear from the the desktop. If you use an Nvidia card, installing Bumblebee could be a temporary solution: https://wiki.ubuntu.com/Bumblebee

share|improve this answer
I've got a ThinkPad T430u with a dedicated nvidia card but I disabled it in the BIOS and never installed any extra drivers or added 'x-swat' or edgers ppa since the intel HD4000 worked perfectly out of the box and I had been running this setup without problems for about 2 months –  Daniel May 1 '13 at 16:03
The behaviour of my Asus U36SD seems to confirm that it is a problem with the combination of two GPUs (Intel/Nvidia). I will post an answer explaining how I fixed it. –  Thomas Arildsen May 2 '13 at 10:05

When I accidentally upgraded from 12.04 LTS Ubuntu to 13.04, I too had to face the same issues such as missing side menu bar, no window options, not being able to switch between applications (alt-tab) and I couldn't even drag windows on the screen. After following so many options I ended up with the following set of commands to fix these issues.

sudo apt-get remove aspell #may not be relevant
sudo apt-get remove dictionaries-common

reboot (you can use sudo reboot)

sudo apt-get install compizconfig-settings-manager
sudo apt-get install dictionaries-common
sudo apt-get install lightdm

reboot (you can use sudo reboot)

dconf reset -f /org/compiz/
unity --reset-icons & disown

I actually removed aspell because of conflicting dependency. This might not have any correlation between this issue. I think re-installing lightdm and resetting compiz helped me in fixing this.

share|improve this answer

The first answer works fine, except I needed to install Unity itself:

sudo apt-get install unity

then run:


and enable Unity :)

share|improve this answer
forget to mention it's happens on my new ubuntu 13.10, never before! –  sobi3ch Nov 26 '13 at 1:24

I had pretty much the same problem under 12.04. Unity was slow with my aged GPU, so I was using Unity 2d as my desktop for months. For no apparent reason, it suddenly refused to display launchpad and title bar (for all users). Reenabling Unity in CCSM as sugggested here was part of the solution, but none of the other measures suggested here, there or in several other related threads, including, but not limited to:

  • Reinstalling unity

  • Reinstalling ubuntu desktop

  • Removing all relevant (e.g. compiz, gconf, etc.) configuration information

helped me to completely resolve these symptoms under 12.04 (64 bit).

unity --reset

would not work for me. After delivering a variety of error and information messages, it would always hang at:

Setting Update "run_key"

as shown in the log posted in the thread titled "unity has vanished" for unity run with no arguments.

I noticed that the error message delivered by:

/usr/lib/nux/unity_support_test -p

was similar to some of the errors reported by unity --reset:

error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory.

After extensive searching, I found the following solution:

  • Get the path of libGL.so.1 by using the command locate libGL.so.1.

  • Add a link to the library in /usr/lib/ as shown in the following example:

    sudo ln -s /usr/lib/i386/mesa/libGL.so.1 /usr/lib

    (courtesy of J.D. Bartlett)

  • Restart the computer.

This not only allowed both unity_support_test-p and unity --reset to run, it also allowed Unity 2D to start. I have no idea what caused my problems, but since creating the links above (several weeks now) I have had no further problems.

share|improve this answer

I had the same problem and all the suggestions above failed for me.

I made the following steps:

  1. Installed kubuntu-desktop as an user interface alternative for Unity (login via ALT + Ctrl + F1, then sudo apt-get install kubuntu-desktop). Sure, you can choose other Unity alternatives.

  2. Restarted the machine and logged in via KDE.

  3. Created a temp user (let's name it alice) with admin rights.
  4. Copied my files in Alice's account.
  5. Deleted the original user (including the files)
  6. Created again the original user (same username, same rights)
  7. Copied the files from backup.
  8. Deleted the temp user (alice).

Then, you don't need KDE anymore. ;-)

share|improve this answer
Shouldn't it be better with juste xfce (not xubuntu-desktop!!) ? I think it's way less heavy to install (kde is so heavy) and not including *-desktop allows to ditch all "recommended" programs. –  MrVaykadji May 24 '14 at 18:45
@MrVaykadji I chose kubuntu-desktop because I didn't remember another one. :-) –  Ionică Bizău May 24 '14 at 19:34
Okay, but installing kubuntu-desktop will create a hell lot of dependencies, that's all I'm saying –  MrVaykadji May 24 '14 at 19:35
KDE is more powerful than xubuntu; so in a certain way: if you accept the overhead of unity and the ubuntu-desktop; then KDE might be the better choice. On the other hand - if your focus is to have a system that reacts immediately you might want to install xubuntu in the first place. With xubuntu, the thunar file manager pops up in a second; nautilus under unity or gnome3; or dolphin with KDE will need at least 3 to 5 seconds. –  EdGunter Jun 4 '14 at 10:22

I had recently edited my .bashrc file with the line guake -r $(hostname) to automatically rename tabs whenever I opened a new tab in guake and everything was working perfectly. Then I restarted my computer a few days later and encountered this problem. I can only assume that trying to start guake without a valid display resulted in some error that completely destroyed something in the unity pipeline.

So if you've recently modified your ~/.bashrc try undoing changes.

share|improve this answer

I just had a black background with a mouse cursor. The following worked for me in addition to enabling the unity plugin again via ccsm, but first I had to do the following because it didn't even properly show the desktop: When doing unity --reset, it stopped at "show session" and some lines before it said "error loading plugin opengl", so i figured this must be related.. and it was! (just be sure to load your specific .so my nvidia installation had a different number of course, just do ls in the folder in described in the link


share|improve this answer

protected by Community Apr 16 '12 at 17:38

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.