Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I plug in my USB hard drive that is formatted with an ext4 partition, the drive is mounted as expected, but at a path that contains the long UUID of the disk; something like:

/media/a1f2e5f6-a9bc-dd2a-c2c9-1f48c39b39ee

Is there a way to automount the drive at a path that is shorter and more snappy? e.g.

/media/my_external_hd
share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

Give the filesystem on your disk a label with the e2label command. For example: if your filesystem is on /dev/hdc1, run sudo e2label /dev/hdc1 my_external_hd. I think you may need to unmount the filesystem with sudo umount /media/a1f2e5f6-a9bc-dd2a-c2c9-1f48c39b39ee before this will work.

To find out what device your mounted filesystem is on, the command mount will give you a list.

share|improve this answer
1  
Perfect. One can also unmount the drive from the right-click menu. –  Henry Gomersall Aug 9 '12 at 13:02
add comment

If you prefer not to use the command line, the Disk Utility (should be installed by default on 12.04) also has this option. Select the device and then select Edit Filesystem Label. When the device is next mounted it will appear under this name instead of the UUID.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.